User’s Manual

Tecplot Chorus 2019 Release 1
# Table of Contents

## 1 Introduction
- Tecplot Chorus Fundamentals ......................................................... 7
- Organizing Your Study ...................................................................... 9
- Tagging Image and Data Files .......................................................... 10
- Interface ......................................................................................... 11
  - Menu Bar ..................................................................................... 12
  - Toolbar ......................................................................................... 12
  - Sidebar ......................................................................................... 14
  - Workspace .................................................................................... 14
  - Status ........................................................................................... 15
- Sessions ........................................................................................... 15
- Getting Help .................................................................................... 16

## 2 Projects
- Welcome Screen ................................................................................ 17
- Opening Projects ............................................................................. 18
- Creating Projects ............................................................................ 18
  - Importing with the Delimited Text Reader .................................. 19
  - Importing with the File Crawler ................................................. 23
- Appending To a Project .................................................................... 28
- Calculated Variables ........................................................................ 29
  - Expression Syntax ........................................................................ 30
- Changing Variable Nature ................................................................ 31
- Removing Links to Files .................................................................. 31
- Exporting Projects ........................................................................... 32
- Modifying the Root Path .................................................................. 32
# Exploring Your Results

<table>
<thead>
<tr>
<th>Context Menus in Views</th>
<th>33</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filters</td>
<td>34</td>
</tr>
<tr>
<td>Null Value Filtering</td>
<td>35</td>
</tr>
<tr>
<td>Managing Filters</td>
<td>36</td>
</tr>
<tr>
<td>Resetting Filters</td>
<td>37</td>
</tr>
<tr>
<td>Matrix Views</td>
<td>37</td>
</tr>
<tr>
<td>Matrix View Properties</td>
<td>38</td>
</tr>
<tr>
<td>Selecting Cases in a Matrix View</td>
<td>39</td>
</tr>
<tr>
<td>Tag Groups</td>
<td>39</td>
</tr>
<tr>
<td>Scatter Plots</td>
<td>41</td>
</tr>
<tr>
<td>Scatter Plot Properties</td>
<td>42</td>
</tr>
<tr>
<td>Color Legend Dialog</td>
<td>43</td>
</tr>
<tr>
<td>Zooming, Translating, and Rotating Scatter Plots</td>
<td>44</td>
</tr>
<tr>
<td>Selecting Cases in a Scatter Plot</td>
<td>45</td>
</tr>
<tr>
<td>Line and Symbol Plots</td>
<td>46</td>
</tr>
<tr>
<td>Zooming and Translating Line and Symbol Plots</td>
<td>47</td>
</tr>
<tr>
<td>Line and Symbol Plot Properties</td>
<td>47</td>
</tr>
<tr>
<td>Selecting Cases in a Line or Symbol Plot</td>
<td>48</td>
</tr>
<tr>
<td>Setting Axis Details</td>
<td>48</td>
</tr>
<tr>
<td>Table Views</td>
<td>49</td>
</tr>
<tr>
<td>Constraint Visualization with Table Views</td>
<td>49</td>
</tr>
<tr>
<td>Selecting Cases in a Table View</td>
<td>50</td>
</tr>
<tr>
<td>Editing Values</td>
<td>50</td>
</tr>
<tr>
<td>Deleting Variables</td>
<td>50</td>
</tr>
<tr>
<td>Deleting Cases</td>
<td>50</td>
</tr>
<tr>
<td>Table View Properties</td>
<td>51</td>
</tr>
<tr>
<td>Selected Cases Sidebar</td>
<td>51</td>
</tr>
<tr>
<td>Constraint Visualization with the Selected Cases Sidebar</td>
<td>52</td>
</tr>
</tbody>
</table>

# Analyzing Individual Cases

<table>
<thead>
<tr>
<th>Viewing Images</th>
<th>53</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image Viewer Controls</td>
<td>54</td>
</tr>
<tr>
<td>Image Viewer Properties</td>
<td>54</td>
</tr>
<tr>
<td>Removing Cases from the View</td>
<td>55</td>
</tr>
<tr>
<td>Exporting Images</td>
<td>55</td>
</tr>
<tr>
<td>Showing Image Differences</td>
<td>55</td>
</tr>
<tr>
<td>Viewing Data</td>
<td>56</td>
</tr>
<tr>
<td>The Chorus Sidebar</td>
<td>59</td>
</tr>
<tr>
<td>Creating Images</td>
<td>60</td>
</tr>
<tr>
<td>Creating Data Files</td>
<td>63</td>
</tr>
<tr>
<td>Extracting Variables from Data Files</td>
<td>63</td>
</tr>
<tr>
<td>Recording an Analysis Macro</td>
<td>64</td>
</tr>
<tr>
<td>Custom Actions</td>
<td>65</td>
</tr>
</tbody>
</table>

# Surrogate Models

<table>
<thead>
<tr>
<th>Getting Started with Surrogate Models</th>
<th>67</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum Number of Cases</td>
<td>68</td>
</tr>
<tr>
<td>Using a Surrogate Model</td>
<td>69</td>
</tr>
</tbody>
</table>
Appendices

A Loading Other Data Formats ................................................................. 79
Editing a Loader Description ................................................................. 80
Creating Other Loader Descriptions ....................................................... 80
Multiple Instruction Templates .............................................................. 81
XML Schema ............................................................................................. 81
Alternative Method .................................................................................. 81
Creating the Macro File .......................................................................... 82
Viewing The Data Files ............................................................................ 83

B Actions .................................................................................................. 85
Enabling the Example Actions ................................................................. 85
Configuring the Example Actions ............................................................ 86
ExtractDataWithTecplot360.py ............................................................... 86
OpenWithParaview.py ............................................................................. 86
Creating Your Own Actions .................................................................... 87

C Configuration ....................................................................................... 89
ImageListViewStylesheet, ImageTableViewStylesheet ......................... 89

D License Management ........................................................................... 91
Entering Your License ............................................................................. 91
Evaluation License Setup ........................................................................ 93
Single-User License Setup Using An Activation Code ............................ 93
Single-User License Setup Using A License File .................................... 94
Network License Setup .......................................................................... 95
License Roaming ..................................................................................... 95
Starting Roaming .................................................................................... 96
Ending Roaming ..................................................................................... 96
RLM_ROAM ............................................................................................ 96

E Glossary ............................................................................................... 99

Index ....................................................................................................... 109
Introduction

Tecplot Chorus provides a robust framework for managing CFD projects, such as parametric studies, that require multiple simulation cases with tools to evaluate the results. You can evaluate overall system performance and visually compare tens or thousands of simulation cases in a single environment, helping you make decisions faster and with more confidence than ever before.
Introduction

Tecplot Chorus’s flexible data management system and sophisticated analysis and collaboration tools work equally well with a handful of cases or thousands, letting you quickly discover trends and anomalies even in large studies and giving you deeper insight than ever before into the underlying physical phenomena.

With Tecplot Chorus, you can:

- Gather metadata, data, and images from the names of the folders in your solver output or from generated CSV (comma-separated value) files, and append new data whenever additional cases are available or when variables or auxiliary files are added.
- View your cases in a variety of layouts, or even in more than one layout at a time, and filter cases to quickly locate the ones you’re interested in. Use the plot views to help communicate your results to others.
- Compare images and data files from multiple cases and highlight the differences among them.
- Perform “deep dives” using the full power of Tecplot 360 EX to inspect, visualize, and analyze the raw data for one or more cases.
- Generate new images or data files for some or all cases from the raw data.
- Create a surrogate model to fill in the gaps between your cases, helping you to better visualize your results. Data from the surrogate model can be exported.

Tecplot Chorus never modifies your data. Any information you create is stored in the Tecplot Chorus project, or in folders separate from your original files.

1 - 1 Tecplot Chorus Fundamentals

Tecplot Chorus organizes your results into projects. (See Chapter 2: “Projects”.) A project typically corresponds to a single parametric CFD study you have performed; this is not, however, a requirement. There might also be situations in which you would want to create more than one Tecplot Chorus project from a single CFD study or to create one project combining multiple studies.

A Tecplot Chorus project contains not the complete data from each CFD case, but the independent variables (parameters) given to the solver, and the dependent variables (outputs) generated by the solver. Additionally, the project contains links to images and data files associated with each case, if any.

Projects are stored in a file with a name ending in .chprj. This file may be located on a network for easy access by members of a team; however, only one user can use the project at a time.

The input parameters and result variables for each case (often referred to as metadata) are imported to a project either by reading a CSV file or by extracting values from the names of the folders in which the cases are stored—or both techniques may be used. If you run additional cases, Tecplot Chorus can update the project with just the data from the new cases.

Once you have created a project and imported metadata from your study into it, you can view the results of your study in a number of ways (see Chapter 3: “Exploring Your Results”).

- **Table** - A spreadsheet-like table showing you the values of independent and dependent variables for all cases.
- **Matrix** - A grid view that shows you an image of each case for combinations of two or three variables. (If you don’t have such images, Tecplot Chorus can make them for you as a batch operation, applying any desired visual style.)
- **Plots** - Various graphical representations of the relationships between dependent and independent variables in your study, including a line/symbol plot, a 2D scatter plot, and a 3D scatter plot.
These views are readily filterable, so you can easily home in on the cases you're interested in. You can select one or more cases and view any images associated with them, or see the differences between cases based on their images, and do a "deep dive" into the solution's full data set by opening it in Tecplot 360 EX. (See Chapter 4: "Analyzing Individual Cases").

Tecplot Chorus can also generate a surrogate model that helps fill in the gaps between your cases to help you detect trends and anomalies (see Chapter 5: "Surrogate Models"). Data from this model may be exported and used to help predict, refine, or sanity-check future cases in the study.

1 - 1.1 Organizing Your Study

Tecplot Chorus works best when all of the image and data files related to a study are organized into folders inside a single hierarchy, with all of the files related to a single case in the same folder. Tecplot Chorus will import your data in one of the following ways:

- By reading variable values and auxiliary file names from a comma-separated value (CSV) file. It may be possible to configure your solver to generate such a file, or you may use additional software or scripts to generate the CSV file during a post-processing step. Each row in a CSV file should contain input and output variable values for one case. Columns containing solely numeric data are taken to be variables. (The text "NaN," meaning "Not a Number," is also accepted in otherwise numeric columns to indicate an invalid or missing value.) Additional text columns may specify paths to associated image and data files or may be used for metadata such as dates, names, and notes.

If you are using only CSV files to import data into Tecplot Chorus, it is not strictly necessary that all your image and data files be in a single folder hierarchy as long as the CSV file contains the complete path of such files starting from the filesystem root (Linux) or a drive or network location (Windows). However, we recommend using paths relative to a project root folder so that you can easily move the project elsewhere if desired. Even if you use absolute paths, you will still need to designate a "root folder" for your project to tell Tecplot Chorus where to store any files it generates.

- By reading variable values from folder or file names and by finding image and data files based on their names. For this to work, your solver must be able to deposit results using folder or file names based on the names and values of each case’s input variables. For example, the result data file for a given case might be in a hierarchy of folders such that its complete path looks like this:
  ...
  ...
  ...
  ...
  ...

It is also acceptable if your solver creates folders at a single level rather than in a hierarchy, as long as the paths contain the required independent variable names and values, such as:

- Using some combination of CSV files and folder/file names. For example, it may be convenient to extract independent variables (input parameters) and find image and data files using the folder hierarchy, while using a CSV file to specify dependent variables (outputs or results from the solver). You will need to import these in two steps, but Tecplot Chorus will match up the data from both sources based on the input parameters for each case. Similarly, you can import multiple CSV files, which may contain different cases, different variables for the same cases, linked data or image files, or a combination of these.
1 - 1.2 Tagging Image and Data Files

Each external file image or data file is identified by a tag, rather than by file name, within Tecplot Chorus. This way, images or data files that have the same sort of content, but whose filenames vary, can be brought together under a single identifier—the tag—in your project. When comparing images or data files, only files having the same tag may be compared.

For example, you might tag files as Data, Image and/or Layout if you have only one of each kind of file. If you have multiple images, you could tag them Pressure Contour, Streaklines, and so on, according to what they show. The tagging scheme you use is entirely up to you.

Tags cannot be changed once they have been added to a project, although they can be removed and re-added. A few moments’ consideration when linking image and data files can make things go more smoothly, especially when you will be working with others on analyzing your results.

It is not required that every case in a project have an associated file for each tag. For example, if you only have contour images for some of your cases, you could still assign these images a tag called “Contour Image” without error. The tag would merely be unavailable for cases that do not have an associated contour image.

For some kinds of data, it is possible to associate more than one file with a tag, and in some cases it is required. The following types of files are limited to one file having a given tag per case:

- Images (.jpg, .png files)
- Tecplot layouts (.lay files)
- Tecplot layout packages (.lpk files)

Some non-Tecplot data formats, such as Fluent and PLOT3D, use two physical files per data set, one for the coordinates and one for the rest of the variables. In this case, you must give both files the same tag when adding them to the project so that Tecplot Chorus will know they should be opened together when you view the case’s data.

For more information on working with non-Tecplot data formats, see “Loading Other Data Formats” on page 79.

When you append new data to a project, you may not use a tag that already exists in the project if any of the cases with which you associate new files already have any files with that tag.

Although only one image file per case may be associated with a tag, you may create a tag group to collect related images together. Tag groups provide an easy way of viewing related images in some Tecplot Chorus windows and also allow you to specify the order in which images in the group appear in those views.
The main Tecplot Chorus user interface is divided into five sections.

- **Menu bar** - Pull-down menus at the top of the screen that provide access to Tecplot Chorus features. (See Section 1 - 2.1 “Menu Bar.”)
- **Toolbar** - A row of buttons just below the menu bar that provide one-click access to commonly-used Tecplot Chorus features. (See Section 1 - 2.2 “Toolbar.”)
- **Sidebar** - Initially displayed on the left side of the Tecplot Chorus window, contains the Filter panel for filtering data and the Properties panel for changing the settings of various types of plot and view windows. These panels can be moved independently to the right edge of the window or moved out of the window entirely (for example, to a second display).
- **Workspace** - The largest section of the main Tecplot Chorus window holds sub-windows that show various analysis views of your projects. You can have multiple sub-windows open at a time and move, resize, and tile them. They can also be moved outside the main window if desired.
- **Status** - A line at the bottom of the Tecplot Chorus window that displays information about what the program is working on at the moment. When a project is open, it also shows the status of background jobs and provides easy access to the Manage Jobs feature.
Introduction

1 - 2.1 Menu Bar

The Tecplot Chorus menu bar appears at the top of the workspace and is divided into five broad classes of functionality.

- **File** - Open and save session files (see Section 1 - 2.6 “Sessions”). Create or open projects (see Chapter 2: “Projects”). View the Dashboard (see Section 2 - 1 “Welcome Screen”). Exit Tecplot Chorus.
- **Edit** - Undo and redo actions.
- **View** - Open various types of views of your project (see Chapter 3: “Exploring Your Results”). Also reset any of these to their default settings. Show or hide the sidebar panels.
- **Project** - Manage the current project (see Chapter 2: “Projects”). Append additional data; set root path; change variable nature. Calculate new variables from existing ones. Export data from the project. Remove links to auxiliary files.
- **Surrogate Model** - Change surrogate model settings (see Chapter 5: “Surrogate Models”).
- **Help** - Get help with Tecplot Chorus. Edit licensing details and display information about the product.

We recommend taking a few moments the first time you use Tecplot Chorus to familiarize yourself with the menus.

1 - 2.2 Toolbar

The Tecplot Chorus tool bar, positioned by default just below the menu bar, provides single-click access to commonly-used features and views. From left to right, the buttons are divided into three categories.

**Session Management**

Allows you to load and save your active session in a file. A session (.chses file) stores information about the open project, all open windows, and the state of the Tecplot Chorus user interface, so when you reopen it you are right back where you were when you saved it. See Section 1 - 2.6 “Sessions” for more information.

**Open Session**

**Save Session**
Project Analysis

Give you various views of the results in your projects. See Chapter 3: “Exploring Your Results” for more information.

You may have any number of any of these plots and views open simultaneously, subject only to the limits of your operating system, available memory, and good taste.

- New Matrix View (see Section 3 - 3 “Matrix Views”)
- New 3D Scatter Plot (see Section 3 - 5 “Scatter Plots”)
- New 2D Scatter Plot (see Section 3 - 5 “Scatter Plots”)
- New Line or Symbol Plot (see Section 3 - 6 “Line and Symbol Plots”)
- New Table View (see Section 3 - 8 “Table Views”)

View Management

- Tile Windows - Tidy up your plot and view windows so you can see all of them. This tool is available only when at least one plot or view window is open.
- Select - Lets you select individual cases or groups of cases in plots and other data views.
  Hold the Control key while clicking to toggle the selection status of the clicked case.
  Drag a rectangle or (in some views) hold Shift while clicking to select groups of cases.
  Hold the Control key while dragging to add the chosen items to (or remove them from) the existing selection rather than making a new selection.
- Translate - Lets you move 3D plots within their window. For 2D and line plots, the axes stay in place while the data moves (that is, the axes' ranges change).
- Rotate - Lets you rotate 3D plots. Not available for 2D or line plots.
- Zoom - Lets you zoom in and out of plots.
  - In 2D plots, drag a rectangle around a region you wish to fill the window; the axes stay in place while the data moves (that is, the axes' ranges change).
  - In 3D plots, hold the right mouse button and drag the mouse up or down to zoom in or out.
  You may also zoom plots when any tool is active by placing the mouse pointer in the window to be zoomed and moving the mouse's scroll wheel.
1 - 2.3 Sidebar

The Tecplot Chorus sidebar has two panels. These panels may be dragged from the Tecplot Chorus main window to make them independent windows that may then be positioned anywhere on your computer’s displays. They may also be docked to any edge of the main Tecplot Chorus window in a manner much like the Toolbar. Although they may be docked to the top and bottom edges, the left and right edges are more useful places for them.

If you attempt to dock both sidebar panels in the same location, Tecplot Chorus will display only one at a time, and you can switch between them using tabs at the bottom of the sidebar area.

The panels can also share space (drag one on top of the other, but toward the top or bottom end), in which case you can drag the divider between them to determine the allocation of space between the two panels.

The available sidebar panels are:

- **Filters** - Sets the range of data displayed in plot, table, or matrix views (see Section 3 - 2 “Filters”) and the filters displayed.
- **Properties** - Sets options for plots and other views. The exact controls available depend on the type of window that is active (a 3D Scatter Plot’s properties panel is shown here).

1 - 2.4 Workspace

The Tecplot Chorus workspace displays the views of the current project, including tables, matrices, and plots. From these windows, you can open additional windows, for example to view or compare images from a case. These also appear in the workspace. Views of data files appear separately in Tecplot 360 EX.

Windows can be resized by dragging from the edges. The window’s title bar also includes the usual buttons for closing, minimizing, and maximizing the window. (If a window is maximized, these buttons are above the right edge of the toolbar.)

Any window may be freed from the workspace by dragging it out of the main Tecplot Chorus window. At this point, it may be moved to another monitor, maximized to fill the screen, and so on. These windows
automatically appear in front of the main Tecplot Chorus window. Closing the emancipated window will return it to the Tecplot Chorus workspace.

1 - 2.5 Status

The Tecplot Chorus status line displays the name of the currently open project, along with progress information for any background jobs currently in progress. The status bar appears when a project is active. (It is not initially visible when you launch Tecplot Chorus.)

At the right end of the status bar is information on any background extraction jobs being performed by Tecplot Chorus. Click Manage Jobs to see the status of individual jobs or to cancel a job (see Section 4 - 3 “Creating Images”). This button is not available when there are no active background jobs or when no project is open. A green circle in the Manage Jobs button indicates that a background task has recently completed and is ready for your attention.

1 - 2.6 Sessions

In Tecplot Chorus, a session refers to the current state of the software, including the current project, tag groups you have defined, any open plots or views, and all surrogate model settings. Image difference windows, however, are not part of the session.
Introduction

Sessions are useful for two different scenarios:

• Save a session when you quit Tecplot Chorus for the day, and pick up where you left off the next time you use the software

• Save one or more sessions as “templates” for the views you typically work with, then start using Tecplot Chorus by using one of these sessions

You may save your session to a .chses file by choosing File > Save Session or by clicking the button on the toolbar. When later opened using File > Open Session or the button, Tecplot Chorus is restored to its state at the time the session file was saved.

1 - 3 Getting Help

Tecplot Chorus includes the following documents to help you learn about the software.

• User’s Manual - Explains the product's features and user interface.

• Getting Started Manual - Tutorials that will give you hands-on experience with the product.

• Release Notes - Late-breaking information on updated product features.

If you get stuck, don’t panic! Help is available right inside Tecplot Chorus. Simply choose Tecplot Chorus Help from the Help menu to see a table of contents, or click the Help or ? button in any dialog or sidebar that has one to get help for that part of the software.

If you have an active TecPLUS subscription, you may also call +1 425 653 9393 to reach Tecplot’s Technical Support staff. Assistance is available by telephone from 6:30 A.M. to 5 P.M. Pacific. Our Technical Support staff can also be reached at support@tecplot.com.
Projects

Tecplot Chorus manages the cases that make up your parametric CFD studies as projects. A project stores your cases’ metadata (the input and result variables for each case) as well as all the information you create in Tecplot Chorus. The project also contains links to auxiliary files associated with each case, such as images and data.

Often, a project will comprise the cases for a single study, but this is not a requirement of Tecplot Chorus; it is possible, and useful, to use projects to organize multiple related studies, or only a subset of the cases in a study.

Each project you create in Tecplot Chorus is stored in a project file (extension .chprj). This file may be sent to or shared with other Tecplot Chorus users to give them access to the project.

Tecplot Chorus does not copy your data files into the project; these files, and related files such as images and layouts, can be stored on your workstation's hard disk (if only you need access to them) or, more commonly, in a network location accessible to everyone working on a study.

Make sure that everyone who will work on a project accesses the associated files using the same path. On Windows, we recommend using a UNC path (starting with \\) rather than a mapped drive letter; this way you don’t need to configure anything on the individual workstations. There are often differences in how Linux and Windows computers address network resources, so Tecplot Chorus works best when all members of a team use the same operating system.

It is never necessary to explicitly save a project. Everything you do in Tecplot Chorus is saved as you work. Your original data files are never modified.
2 - 1 Welcome Screen

The Welcome Screen is the screen that initially appears when you launch Tecplot Chorus. You can also display the Welcome Screen at any time by choosing View > Welcome Screen.

The Welcome Screen lists sessions and projects you have recently worked with, along with useful resources for learning about working with Tecplot Chorus. Simply click one of these to open it in Tecplot Chorus and display a Table View of its data in the workspace.

You may also click the Create Project button to create a new project. See Section 2 - 3 “Creating Projects” for more information.

2 - 2 Opening Projects

You can open a project in Tecplot Chorus in one of two ways:

- Recently-used projects appear in the Welcome Screen and can be opened from there. (See Section 2 - 1 “Welcome Screen”)
- You may also open a project by choosing File > Open Project (or by clicking Open Project in the Welcome Screen) and selecting the project in the Open Session File dialog. Tecplot Chorus projects have the filename extension .chprj.

2 - 3 Creating Projects

You can start creating Tecplot Chorus projects in three ways:

- By clicking the Create New button in the Welcome Screen (see Section 2 - 1 "Welcome Screen")
- By choosing File > Create New Project
- By choosing File > Open CSV Project (a shortcut for creating a project from a comma-separated value file using the Delimited Text Reader; see note at Importing with the Delimited Text Reader).

In either case, you will be asked to name and save the file using the Save Your Project File dialog. Then Tecplot Chorus launches the Create Project wizard, a sequence of screens that guides you through the steps in creating the project.
Tecplot Chorus can import cases into the project using two different methods: by reading a delimited text file (such as a CSV file) and by “crawling” a folder structure in which the files associated with each case have been stored. The initial steps for creating a new project are the same regardless of which method you use. Then you choose an importer, which determines the remainder of the steps.

Step 1 Select Data Importer

Choose how you wish to import your data on this page of the wizard.

- **Delimited Text Reader** - Reads variable values and names of auxiliary files from a delimited text file—that is, one in which each line represents a case, and the variable values for each case are separated by commas, white space, or another delimiter. A CSV (comma-separated value) file is one type of delimited text file.

- **File Crawler** - Scans the folder structure that contains your auxiliary files, extracting variable values from the names of files and folders and detecting each case's auxiliary files by name.

The importer you will want to use depends largely on what solver you are using to process your cases and which fits better with your methods and workflows.

After you choose your importer, the wizard continues to the next step automatically. The remaining steps of the wizard are determined by the importer chosen. Continue with either Section 2 - 3.1 “Importing with the Delimited Text Reader” or Section 2 - 3.2 “Importing with the File Crawler” as appropriate.

2 - 3.1 Importing with the Delimited Text Reader

The Delimited Text Reader reads variable values and names of auxiliary files from a CSV (comma-separated value) file or other delimited text file. The first row of the file must specify the name of each variable.

The second row of the file may be used to specify a variable nature for each column. Each column of this second header must contain one of the following values:

- **Independent** - The column is an independent (input or parameter) variable.
• **Dependent** - The column is a dependent (output or result) variable.
• **Other** - The column is data such as a note or comment about each case.
• **Auxfile** - The column is a link to an auxiliary file (external data or image file).

Values are not case-sensitive. If the second row of the file contains any values other than the above, that row is taken to be the first row of data rather than the optional second header row.

If multiple columns in a delimited text file have the same variable name, these are disambiguated upon import by appending a number in parentheses to the name of the variable.

Subsequent rows should specify the variable values for each case, matching the order in the first row. Columns containing solely numeric data are taken to be numeric variables. (The text “NaN,” meaning “Not a Number,” is also accepted in otherwise numeric columns to indicate an invalid or missing value.) In a later step, you will choose (or change, if this has already been specified in the second header) which variables are dependent and independent, and which columns contain links to auxiliary files.

Excess whitespace is stripped when reading a delimited text file. For files not using tabs as a delimiter, this includes tabs as well as spaces.

The file `Example3.csv` located in the `sampledata/example3` directory of the Tecplot Chorus installation illustrates the required format.

Perform the following steps when importing a delimited text file into a project.

If the file being imported uses commas as delimiters, i.e., it is a Comma-Separated Value (CSV) file, you can use **File > Open CSV Project** to open it in a single step. Tecplot Chorus automatically determines the type of each column and links auxiliary files to the project where appropriate. The nature of any numeric variable is set to Independent, but this may be changed after import; see "Changing Variable Nature" on page 31.

The root path of the project is set to the directory containing the CSV file; your auxiliary files should generally be in the same directory, or in subdirectories under it, though they need not be. We recommend using auxiliary file paths relative to the root path wherever possible, as this will make it easier to move the project if necessary; however, absolute paths—those beginning with a drive letter or double-backslash (Windows) or a slash (Linux)—are also accepted.

A new `.chprj` file is created in the root directory next to the CSV file with the same base name. (If a `.chprj` file with this name already exists, you will be asked to name and save the file.) You probably will open this file in the future, rather than the original CSV file. You may invoke this feature when launching Tecplot Chorus from the command line using the `--csv-file` flag; for example: `chorus --csv-file my-data.csv`. Tecplot Chorus then opens the CSV file upon launch.
Creating Projects

**Step 2  Select File**

In this step of the wizard, select the file to be imported. Click the **Browse** button, then choose the file using the Open dialog, and click **Open**. Then choose the delimiter that appears between columns (a comma for CSV files) and click **Next** to proceed to the next step of the wizard.

**Step 3  Specify Root Folder**

Tecplot Chorus needs to know where the data files from your project are. Click **Browse**, use the Open dialog to navigate to the top-level folder of the structure that contains your data files, and click **Select Folder**. Then click **Next** to proceed to the next step in the wizard.
Step 4 Specify Files to Link

In this step, you can indicate which columns of the file (if any) contain the paths of supporting files, such as images and data files. Files linked must be assigned a tag so that you can easily choose which auxiliary file you want to view later (see Section 1 - 1.2 “Tagging Image and Data Files”).

Mark the checkbox next to any column name that you want to treat as a file to be linked. Any column not used for linked files will be imported as a string (text) variable into Tecplot Chorus. There may be only one image file matched for a given tag. For data files other than Tecplot layouts (.lay files) and layout packages (.lpk files), you may give multiple files the same tag; they will be opened in the order the corresponding columns appear in the delimited text file.

The paths specified for your auxiliary files may be either relative to the project’s root folder, in which they should not begin with a drive letter, a slash or a backslash, or they may be absolute paths, beginning with a drive letter or double-backslash (Windows) or a slash (Linux). Generally, relative paths are preferred, since they make it easier to move the project if necessary.

Some non-Tecplot data formats, such as Fluent and PLOT3D, use two physical files per data set, one for the coordinates and one for the rest of the variables. In this case, you must give both files the same tag when adding them to the project so that Tecplot Chorus will know they should be opened together when you view the case’s data.

The tag defaults to the column name, but it may be edited if desired (for example, when working with your project, you may want to be able to open a case’s “Contour Layout” rather than its “contourlpk”).

Click Next to move to the next step of the wizard.
Creating Projects

Step 5  Confirm Data

Tecplot Chorus now gives you a chance to confirm the data that will be imported. You may also edit the Display Name or Nature of any variable being imported.

- **Display Name** - The name by which a variable is known in Tecplot Chorus for axis labeling and other uses. This feature can also be used to clarify names or make them more consistent; for example, if Mach number is “M” in your data files, you could reassign it to “Mach” in your project to make its meaning more apparent.

  Tecplot Chorus does not allow leading or trailing whitespace in variable names or display names, and strips extra tabs and spaces from the beginning and end of all names.

- **Nature** - Each numeric variable can be Independent (input), Dependent (output), or Other. “Other” implies that the variable is not an input or output variable used or calculated by the solver. String (text) variables are always Other.

You may not use the names Case ID and Case Status for your variables. These names are reserved for internal Tecplot Chorus variables. If you have variables with these names in your data, you can use this feature to "rename" them inside Tecplot Chorus (perhaps prepending "External" or "Original").

When you have edited your variables’ Display Names and Natures as desired, click **Finish** to close the wizard and perform the import. Nothing is added to the project until you click **Finish**.

The new project is automatically opened into a clean workspace. See Chapter 3: “Exploring Your Results” for your next steps.

2 - 3.2  Importing with the File Crawler

The File Crawler scans a chosen folder structure, extracting variable values from the names of files and folders and detecting each case's auxiliary files by their names. Perform the following steps when extracting metadata into a project using the File Crawler.
Step 2 Specify Root Folder

On this page, click Browse and navigate to the folder that contains all your cases, then click Select Folder. The File Crawler will examine all folders inside the root folder you select, and the folders inside them, and so on, to any depth. Click Next to proceed to the next step of the wizard.

Step 3 Identify Data

The File Crawler extracts variable names and values from the names of the files and folders inside the root folder. The entire path of each folder, relative to the root folder selected on the previous page, is scanned for the keywords you define here. The value immediately following each keyword is taken as the value of the named variable for all the cases in the folder.

For example, you may have a set of folders named M1.0, M1.1, M1.2, M1.3, etc., that contain simulation results at various Mach numbers. Inside the Mach folders are additional folders representing the various values of another variable, and inside these, folders representing values of a third variable. The File
Creating Projects

Crawler recognizes that the digits in the outermost folders’ names represent Mach number, and each case is assigned a Mach number derived from the name of the folder or folders it is inside.

All files with identical combinations of parameter values are considered part of a single case, with the case being assigned a unique internal identifier. Folder hierarchy is not considered when detecting cases.

For each value you wish to extract, you must specify the Source Name, which is text that uniquely identifies the value in the file path, and indicate whether the value is a number or a string of characters. You must add these in the order they appear in your folder hierarchy, shallowest first (that is, leftmost in the textual representation of the folder path).

A directory separator ("/") may be included in Source Name patterns. For example, if the folder hierarchy contains only variable values with no other identifying text, such as /1.0/1.1/1.2, the "/" character itself can be specified as three different Source Name patterns; the resulting variables can then be given names in the Confirm Data step.

To add a variable:
1. Click Add.
2. Enter text that immediately precedes the value you wish to extract into the new, blank Source Name field. If there are underscores, periods, spaces, or other characters in the file path between the name and the value, enter these as well; every character up to the value you wish to extract must be matched.
   
   Observe the scrolling list of file paths at the bottom of the dialog for instant confirmation of your entry. As you type the Source Name, the text you enter appears in red in all the paths. When Tecplot Chorus recognizes a value immediately following a Source Name, that value appears in blue in all the paths. Scroll through this list to make sure Tecplot Chorus is picking up all the values you want.
3. Choose Number or String (text) data type for the new variable.

You may add and edit entries in this dialog, or delete an entry entirely by selecting it and clicking Remove. When you have specified all the variables you wish to extract, click Next.
Step 4 Specify Files to Link

In this step, you can indicate which files are images and data files. Each such file will be linked to a case and assigned a tag so that you can easily choose which auxiliary file you want to view in Tecplot Chorus (see Section 1.2 “Tagging Image and Data Files”).

To link files:

1. Click Add.

2. In the new Pattern field, enter text that uniquely identifies the supporting files you wish to link to your cases. The asterisk may be used as a wildcard to match any number of characters; for example, *.dat matches any file with a .dat extension. A question mark matches any single character. As you type, the scrolling list of filenames at the bottom of the dialog highlights matching files in blue, so you can instantly see when you have specified the files you want.

Generally, you should use the specific names of each file you wish to import to the extent possible. When using wildcards, it is very easy to accidentally match files you do not intend to match and give them the wrong tag. (Files linked in error can, however, be removed from the project via the Remove Links to Files option on the Project menu.) If you do use a wildcard, use as much of the typical file’s name as possible, using a wildcard only for parts that change, and review the scrolling list at the bottom of the window carefully to make sure you only have only matched the files you intended.

As in the earlier Identify Data step, you may include a directory separator (“/”) in your pattern to match only files in particular directories. The pattern is matched against the entire path to each candidate file. For example, if your project is organized so that each case has subdirectories called contour and wireframe, each of which contains an image called image.png, the patterns contour/image.png and wireframe/image.png may be used to link these images.
Creating Projects

You may match at most one image file for a given tag. For any data file other than Tecplot layouts (.lay files) and layout packages (.lpk files), you may give multiple files the same tag; they will be opened in the order you enter the patterns in this step of the wizard. If multiple files are matched by a single pattern for a single case, the files will be opened together and in alphabetical order when viewing the case data in Tecplot 360 EX.

Some non-Tecplot data formats, such as Fluent and PLOT3D, use two physical files per data set, one for the coordinates and one for the rest of the variables. In this case, you must give both files the same tag when adding them to the project so that Tecplot Chorus will know they should be opened together when you view the case's data.

3. In the Tag field, enter an identifier by which you will later access matching files in Tecplot Chorus when viewing individual cases. (See Section 1.1.2 “Tagging Image and Data Files”.)

As with the previous step, you may add, edit, or remove entries in this dialog (by clicking the entry to be removed, then clicking Remove). Click Next to proceed to the final step.

Step 5 Confirm Data

Tecplot Chorus now gives you a chance to confirm the data that will be imported. You may also edit the Display Name or Nature of any variable being imported.

- Display Name - The name by which a variable is known in Tecplot Chorus for axis labeling and all other uses. This feature can also be used to clarify names or make them more consistent; for example, if Mach number is “M” in your data files, you could reassign it to “Mach” in your project to make its meaning more apparent.

Tecplot Chorus does not allow leading or trailing spaces in variable names or display names and will strip any spaces from the beginning or end of variable names.

You may not use the names Case ID and Case Status for your variables. These names are reserved for internal Tecplot Chorus variables. If you have variables with these names in your data, you can use this feature to "rename" them inside Tecplot Chorus (perhaps prepending "External" or "Original").
Projects

- Nature - Each numeric variable can be independent (input), dependent (output), or other. "Other" implies that the variable is not an input or output variable calculated by the solver. String (text) variables always have the Other nature, but numeric variables may as well.

You can change a variable's nature after the project has been created by choosing Project > Change Variable Nature. For more information, see Section 2 - 6, "Changing Variable Nature".

When you have edited your variables' Display Names and Natures as desired, click Finish to close the wizard and perform the import. Nothing is actually imported until you click Finish.

The new project automatically opens a Table View in the workspace. See Chapter 3: “Exploring Your Results” for your next steps.

2 - 4 Appending To a Project

To add new cases, variables, or auxiliary files to an open project, choose Project > Append Data. As when you initially created the project, you can append using the Delimited Text Reader or the File Crawler.

It is not necessary to use the same method when appending that you used when you created the project. In fact, a common work flow is to initially import independent variables and auxiliary files using the file crawler, then append dependent variables from a delimited text file. You may add additional cases, additional links to auxiliary image and data files for existing cases, additional variables for existing cases, or any combination of these.

Tecplot Chorus uses these rules when appending to a project:

- If a case's independent variables match a case already in the project, but there are new dependent variables or linked image or data files, these are added to the existing case.
- If a case has a combination of independent variables that is not already in the project, it is considered a new case, and all variables and linked files associated with that case are added to the project.
- If a new case's independent variable values are already in the project, and one or more existing dependent variables have values different from the ones being imported, you'll be asked how to proceed: apply the new values to the existing cases, or append duplicate cases to the project. If you choose to add duplicate cases, you will have more than one case with the same combination of independent variables in the project. These cases may be distinguished by their Case ID, as this internal variable is unique for every case, even duplicates.
- If a new case's independent and dependent values all match an existing case, the new case is ignored.

The step-by-step procedure is identical to that used when initially creating the project. See Section 2 - 3, "Creating Projects" for detailed instructions.

When importing using the File Crawler, you must re-specify variable names in exactly the same way as when the project was created so that any cases that already exist in the project can be detected and handled correctly.

For the Delimited Text Reader, use the same column names for variables that are already in your project. If the file being appended includes a second header row to specify variable natures, these will be ignored for existing variables, but will be respected for any new variables being added.
2 - 5 Calculated Variables

You can generate new variables by choosing Project > Calculate Variables, which opens the Calculated Variables dialog, shown below. The dialog displays any calculated variables that exist in the project and allows you to add new ones. The new variables are added only after you click OK.

To add new calculated variables to the project:

1. Click the Add button to create a new blank row if one does not already exist.
2. Enter a name for the new variable in the Calc Var Name column. Tecplot Chorus does not allow leading or trailing spaces in variable names and will strip any spaces from the beginning or end of variable names.
3. Enter an expression to be used to calculate the new variable in the Expression column. (See Section 2 - 5.1 “Expression Syntax” for details of what you can enter.)
4. Choose the nature of the variable: Independent (input), Dependent (output), or Other.
5. If you wish to add another variable, go back to Step 1.

If you have entered a variable in error, click the Remove button to remove it. You may not remove variables once they have been added to the project. When you have finished adding calculated variables, click OK. Only at this point are the calculations actually performed for each case and the results added to the project. These calculations will also be performed automatically for any additional cases you may append later.

Calculated variables may not be edited and are displayed with a lock symbol in table views.
2 - 5.1 Expression Syntax

Expressions supported by Tecplot Chorus follow a syntax similar to popular programming and scripting languages.

**Numbers**

Both integers and floating-point numbers in standard or scientific notation, such as 3.1415927 or 6.02e23, may be used.

**Variables**

If a variable name does not contain any spaces or parentheses and is not the same as a function name supported by Tecplot Chorus, it may be referenced in an equation simply by typing its name. Otherwise, its name must be enclosed in backticks `like this`. (The backtick character is typically located at the top left of the keyboard, one row down from the Escape key, and should not be confused with the apostrophe.) Variable names must match case: Alpha is not the same as alpha or ALPHA.

**Operators**

Tecplot Chorus supports arithmetic operations using the following symbols and the standard algebraic order of operations. Parentheses may be used to override order of operations.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>+</code></td>
<td>Addition</td>
</tr>
<tr>
<td><code>-</code></td>
<td>Subtraction</td>
</tr>
<tr>
<td><code>*</code></td>
<td>Multiplication</td>
</tr>
<tr>
<td><code>/</code></td>
<td>Division</td>
</tr>
<tr>
<td><code>^</code></td>
<td>Exponentiation</td>
</tr>
</tbody>
</table>

**Functions**

The following functions are supported.

<table>
<thead>
<tr>
<th>Function</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>sqrt(x)</td>
<td>Square root of x</td>
</tr>
<tr>
<td>exp(x)</td>
<td>e raised to the x power</td>
</tr>
<tr>
<td>ln(x)</td>
<td>Natural logarithm of x</td>
</tr>
<tr>
<td>log(x)</td>
<td>Base-ten logarithm of x</td>
</tr>
<tr>
<td>sin(x), asin(x), sinh(x), asinh(x)</td>
<td>Sine, arcsine, or hyperbolic sine or arcsine of x</td>
</tr>
<tr>
<td>cos(x), acos(x), cosh(x), acosh(x)</td>
<td>Cosine, arccosine, or hyperbolic cosine or arccosine of x</td>
</tr>
<tr>
<td>tan(x), atan(x), tanh(x), atanh(x)</td>
<td>Tangent, arctangent, or hyperbolic tangent or arctangent of x</td>
</tr>
<tr>
<td>rint(x)</td>
<td>Rounds x to the nearest integer</td>
</tr>
<tr>
<td>sign(x)</td>
<td>Returns 1 if x is positive, -1 if negative, 0 if zero</td>
</tr>
</tbody>
</table>
2 - 6 Changing Variable Nature

If you make a mistake when initially choosing the nature of a variable, you can change it after the project has been created by choosing Project > Change Variable Nature. In the Change Variable Nature dialog, choose the desired nature from the pop-up menu to the right of the variable whose nature you wish to change. After completing your changes, click OK.

Changing a variable's nature will affect any surrogate model that uses it.

2 - 7Removing Links to Files

If you have tagged data or image files in error when creating or appending to a project, or if you simply no longer need access to particular linked files, you can delete the tags and the corresponding links. Removing a tag removes it, and all files linked under that tag, from all cases in the project.

Removing tags and links does not remove the actual data or image files from their folder on your hard disk or network. Only the links to these files stored in the project are deleted.

To remove links to files, choose Remove Links to Files from the Project menu, then choose one or more tags and click Remove.
Projects

2 - 8 Exporting Projects

You can export data from Tecplot Chorus projects to a CSV file by choosing Project > Export Data to CSV File. The resulting CSV file will specify all values for all variables and the paths of all linked files in the project. This is a useful format for use with a variety of other software, including Microsoft Excel, for sharing with others, for further processing in your own scripts, or even for manual editing. The CSV file can be re-imported to Tecplot Chorus with minimal loss of information.

Exported projects do not include equations for calculated variables (the values of such variables are, however, included) nor data generated by a surrogate model. The internal Case ID variable maintained by Tecplot Chorus is also excluded. Case Status is exported only if there are inactive cases in the project. Currently, records that have multiple linked files per tag cannot be exported.

The exported CSV file has a second header that identifies the nature of each field (independent, dependent, other, or auxiliary file). In most software, this will appear as the first data row. It may be removed using a text editor if it interferes with the processing of the rest of the rows.

To export surrogate model data, use the Export Derived Data button in the sidebar of a Line Plot or a 3D Scatter Plot (see Chapter 5: “Surrogate Models”).

If you will send the exported project to someone who will not have your data and image files, you might create a compressed ZIP archive containing both the exported data and the necessary files.

2 - 9 Modifying the Root Path

Tecplot Chorus projects may store references to supporting files such as solution data and images as partial file paths relative to a root directory. If you must move the files associated with a project, or if you have received a project file from another Tecplot Chorus user, you may need to change the project's root path to point to where the files are located on your system or network.

To do this, Choose Project > Set Root Path. Then either enter the new path, or click the Browse button to navigate to the new root directory.

This function does not copy or move your auxiliary files to a new location. You must do this yourself in the usual way if it is necessary.
Exploring Your Results

Tecplot Chorus allows you to explore the results in your project in the following ways.

- In a spreadsheet-like table, providing a way to see all values for all cases
- In a matrix of images, letting you filter results and identify cases of interest at a glance
- In a line, symbol, or scatter plot, so you can visualize correlations and overall trends

When you open or create a project (see Chapter 2: “Projects”), the Tecplot Chorus workspace appears with a Table View of the project's data (see Section 3 - 4 “Table Views”).
Exploring Your Results

You can open additional views using commands on the View menu or by clicking a button on the Tecplot Chorus toolbar.

You can save a session file after opening the views you find useful. Next time you want to work with the project, open that session file to load the project and restore the views. See the Save Session and Open Session commands on the File menu.

Each view you open appears in its own window in the Tecplot Chorus workspace. You can open any number of views, including multiple views of a single type (for example, multiple 2D scatter plots showing different combinations of variables, or two tables showing different sections of your results).

When a view window is active, the Filters and Properties panels become active.

- The Filters panel affects all view windows and will be described in the next section.
- The Properties panel, on the other hand, has different options for each type of view and will be described separately for each view.

3 - 1 Context Menus in Views

Right-clicking any case in any plot or view displays a context menu for quick access to frequently-needed tools. These vary slightly by type of view, but may include:

- Viewing auxiliary files such as images or data associated with the case (see Section 4 - 1 “Viewing Images” and Section 4 - 2 “Viewing Data”)
- Generating new images or layout packages for the case (see Section 4 - 3 “Creating Images” and Section 4 - 4 “Creating Data Files”)
- Extracting a variable from a case’s data file (see Section 4 - 5 “Extracting Variables from Data Files”)
- Saving an image of the plot
- Exporting data generated by a surrogate model (see Chapter 5 “Surrogate Models”)
- Setting the case’s variable values as the evaluation point for a surrogate model (see “Setting the Evaluation Point from a Selected Case” on page 74)
- Making the case active or inactive
- Deleting the case from the project
- Custom actions created by you or other Tecplot Chorus users to operate on a case’s data (see Section 4 - 6 “Custom Actions”)
3 - 2 Filters

The Filters panel lets you determine which cases are shown in plots or in a matrix by excluding or including cases in which specified variables have particular values or fall within a certain range. Filters apply globally to all Tecplot Chorus views (there are not separate filters for each window). Changes are applied immediately to all open views.

If the Filters sidebar is not visible, open it by choosing View > Filters. This sidebar may be docked to any edge of the Tecplot Chorus window, combined with the Properties sidebar, or dragged out of the Tecplot Chorus window entirely and positioned on any display.

Each active variable in the project is displayed in the Filters panel along with a control that allows you to restrict the cases included in the plot or matrix based on the variable’s value. (See Section 3 - 2.2 “Managing Filters” to learn how to choose which variables appear in the Filters sidebar.) The sidebar scrolls vertically if not all the filters fit in the sidebar at once.

By default, the Filters sidebar does not have an effect on Table views. You can enable table filtering in the Properties sidebar when a window containing a table is active.

Tecplot Chorus initially displays filters for all the variables in your project. You can change which variables appear in the Filters panel by clicking the gear icon in the Filters panel and choosing Select Filters to Include (see Section 3 - 2.2 “Managing Filters” on page 37).

Constraint Visualization

The filter settings are made visible in the List view, the Selected Cases view, and optionally in the 2D Scatter plot. This feature is called constraint visualization. For more details, see:

- Constraint Visualization with 2D Scatter Plots
- Constraint Visualization with Table Views
- Constraint Visualization with the Selected Cases Sidebar

Filter Types

Tecplot Chorus provides four different types of filters. Initially, parameters having a small number of discrete values use a Checkbox filter, while other variables default to a Range filter. You may, however, change the filter type for any parameter by right-clicking the filter and choosing the desired filter type from the pop-up menu.

- **Range** - Displays only cases where the variable’s value falls within a specified range. Provides a slider control with two handles to specify the minimum and maximum. You may also enter values using the keyboard. A histogram behind the slider gives you a rough idea of the distribution of values in the project.

- **Single Value** - Displays only cases where the variable’s value is exactly the specified value. A handle is provided to choose the value, or you may enter the value using the keyboard. Tick marks under the slider indicate values of the variable that have associated cases.
Exploring Your Results

- Checkbox - Displays a list of the available values for the variable and lets you choose any combination of values by clicking the checkbox next to each. Only cases where the variable has one of the selected values are included in the plot. The number of cases having each value are displayed in parentheses next to the value. Only available for variables having 10 or fewer unique values.

- Listbox - Displays a list of the available values for the variable in a scrolling list. You can choose any combination of values for the variable. Only cases where the variable has one of the selected values are included in the plot. The number of cases having each value are displayed in parentheses next to the value. The Listbox is functionally similar to the Checkbox filter type, but is better suited for variables having a larger number of discrete values. Also, in a Listbox, it is easier to select one value at a time, or to select ranges of values, than in a Checkbox.
  - To select a single value, click that value. All other values are automatically de-selected.
  - To toggle individual values off and on without affecting other values, click each value while holding the Control key.
  - To select a contiguous range of values, click the first value in the range, then click the last value in the range while holding the Shift key. Alternatively, click and drag the mouse through the range.
  - You may select multiple contiguous ranges of values. Select the first range as above, then select the second and subsequent ranges by holding Control while clicking the first value in the range, and Control + Shift while clicking the last value in the range. Alternatively, you can hold the Control key while clicking and dragging the mouse to select additional ranges.

Your filter settings are saved with sessions (see Section 1 - 2.6 “Sessions”).

3 - 2.1 Null Value Filtering

Null values arise from invalid or missing data for a variable. Internally, Tecplot Chorus represents these as the special floating-point value \texttt{NaN} (meaning “Not a Number”), and they will appear as such in the Table view of your project.

You may remove cases having null values from consideration by Tecplot Chorus using filters.

- For Range filters, a checkbox, \texttt{Pass null}, allows you to choose to view cases with null values or filter them out. This checkbox appears only for variables in the project having null values.
- For Checkbox and Listbox filters, “null” appears as a value, along with the other values for a given variable in the project, if there are any cases having a null value for the variable being filtered. You can turn off the checkbox or deselect the value if you don’t want to see such cases.
3 - 2.2 Managing Filters
You can change which variables appear in the Filters panel by clicking the gear icon in the Filters panel and choosing Select Filters to Include. The Select Filters to Include dialog appears.

In the dialog, you can hide filters for any variable, or for whole categories of variables, by clicking the checkbox next to the variable or category. Turning a category on or off enables or disables all variables in that category.

Filters that are disabled here are not displayed in the Filters sidebar and have no effect on the displayed cases.

3 - 2.3 Resetting Filters
You may reset all filters to their default settings (displaying all cases) by choosing Reset All Filters from the gear icon menu in the Filters panel. This does not affect which filters are active.

3 - 3 Matrix Views
To open a new matrix view, choose View > New Matrix View, or click in the toolbar.

Tecplot Chorus’s Matrix view displays thumbnails of images associated with the cases in your project in a grid, allowing you to quickly sanity-check your solutions and dive deeper into any case that looks interesting. These images may be produced by a postprocessor or by Tecplot Chorus itself (see Section 4 - 3 “Creating Images”). Tecplot Chorus links externally-generated images to their case when the project is created (or when data is appended to it).

Rows in the matrix represent values of one parameter, while columns represent values of another. The grid may optionally be broken into pages based on values of a third parameter. Each discrete value of a selected parameter found in the project is given its own row, column, or page, respectively.

If your project is very sparse, or if not all your cases have images associated with them, your matrix may appear mostly blank, and you may have some trouble finding the cases you want. You can use filters (see Section 3 - 2 “Filters”) and the other views to help you home in on cases of interest.

Conversely, a given cell in the matrix could represent more than one case based on values of one or more of the project’s variables that you have not assigned to rows, columns, or pages. For example, if you have
Exploring Your Results

variables $a$, $b$, $c$, and $d$, and have assigned $a$ and $b$ to rows and columns, then a cell at $a=1$, $b=2$ represents cases that have those values of $a$ and $b$ but any values of $c$ and/or $d$, and this could be any number of cases, any of which may have at least one image associated with them.

When more than one case is matched by matrix cell, a [ ] badge appears in the cell with the thumbnail. The actual thumbnail that appears in the cell is a representative image chosen by Tecplot Chorus from one of the cases. You can turn on labels to see exactly which case's thumbnail is being shown (see Section 3.1.1, “Matrix View Properties”), and you can choose the values selected for any variables not employed in the matrix by using a single-value filter (see Section 3.2.2, “Filters”).

Hovering the mouse pointer over a cell reveals the number of additional cases represented by the cell (for cells that match more than one case), along with information about the thumbnail, such as its path and its case’s Case ID.

The Zoom slider at the bottom right of the window adjusts the size of the thumbnails shown in the matrix.

3 - 3.1 Matrix View Properties

If the Properties panel is not visible, open it by choosing View > Properties. This panel may be docked to any edge of the Tecplot Chorus window, combined with the Filters panel, or dragged out of the Tecplot Chorus window entirely and positioned as desired on any display.

You can set the following matrix view properties:

- **Show Labels** - Shows variable values in cells containing an image.
  Click **Select Labels** to choose which variables to display.

- **Rows** - Chooses the variable that will be used to sort your cases into rows.
  You may also choose “Tag.” In this case, each row of the matrix will correspond to one of the tags selected in the Show Images with Tags list, which contains a list of all image tags in the project.

- **Columns** - Chooses the variable that will be used to sort your cases into columns.
  You may also choose “Tag.” In this case, each column of the matrix will correspond to one of the tags selected in the Show Images with Tags list, which contains a list of all image tags in the project.

- **Page By** - Chooses a third variable to be used to sort the matrix into pages.
  If Page By is set to None, the paging feature is disabled and only a single page is shown. If it is set to a variable, the slider below the Page By menu can be used to select a page for each discrete value of that variable. You may also enter a value directly into the numeric field using the keyboard.

- **Tag Groups** - Opens the Tag Groups dialog to allow you to create and modify tag groups. See “Tag Groups” on page 39.

- **Show Images with Tags** - Chooses the image tags or tag groups to be viewed in the matrix.
  Multiple tags or groups may be selected by dragging the mouse, or by clicking using the Control or Shift keys to toggle individual items and make contiguous selections.

If either of the Rows or Columns menus is set to “Tag,” this setting affects how many rows or columns will be displayed; tags that are not enabled here will not have a corresponding row or column.
Tag Groups

Otherwise, this setting determines which tags are chosen for display in cells in the matrix. As described earlier, any matrix cell may represent more than one case. When multiple image tags are selected, a cell may also represent multiple images for a single or multiple cases. A cell that holds multiple images displays the [ ] badge in the corner.

- Selected Image Values - Displays the values of all variables from the cases associated with the selected images in a scrollable table.

If multiple cases are selected, the text "(Multiple values)" appears next to any variable that does not have the same value in all selected cases.

Tags are defined when creating a project or adding data to a project. See Section 1 - 1.2 “Tagging Image and Data Files”.

3 - 3.2 Selecting Cases in a Matrix View

You can select cases using the tool, then perform operations on the selected cases.

- Click a cell to select the cases in it. Any other selected cases are automatically de-selected.
- Click and drag the mouse to select the cases in any rectangular subsection of the matrix. Any other selected cells are automatically de-selected.
- Hold Shift while clicking to select a rectangular range of cells between an initial click and your Shift-click.
- Hold Control while clicking to toggle the selection status of the clicked cell without de-selecting any other cells that are selected.

Control has a similar effect when dragging (to select an additional rectangular subsection of the matrix).

- Click a row or column header to select all cases in that row or column. You may hold Control while clicking to select additional noncontiguous columns, hold Shift while clicking to select a range of rows or columns, or drag across the headers.
- Press Control-A to select all cases.

Cases selected in any view or plot are selected in all open views and plots.

After selecting cases in the table, click the right mouse button on the selection to view or create images or data for a case. See Chapter 4: “Analyzing Individual Cases” for further details on these operations.

The right-click menu also lets you designate the selected cases as active or inactive, which sets the internal variable Case Status accordingly. Filter on Case Status to display only active or inactive cases.

3 - 4 Tag Groups

Tag groups make it easy to organize and work with various combinations of related images. For example, suppose your project contains surface, streamtrace, and volume plots, each from three different angles, for every case you’ve run. You might want to create a set of tag groups that selects all styles of plots from a single angle, and another set of tag groups that selects all angles of a single plot. Any number of tag groups may be created, and each group can contain any of the image tags in the project.

You’ll see your tag groups displayed in the Show Images with Tags list in the Properties sidebar panel of matrix views and of image viewer windows. (Groups are prefaced with “Group:” in this list.) Turning on or off a group activates or deactivates all the tags in the group for display in the matrix or image viewer.

39
Exploring Your Results

just as if you had turned them all on or off individually. The order of the tags in the group determines the order the tags are displayed in image or matrix views.

To edit tag groups, you use the Tag Groups dialog, accessible via the Tag Groups button in the matrix view or image viewer Properties panel.

In the Tag Groups dialog, you can:

- Create a new tag group by clicking the + button.
- Delete a tag group by selecting it in the Tag Groups list and clicking the - button. This does not delete any tags that the tag group contains.
- Delete a tag from a tag group by selecting it and clicking the - button.
- Add tags to a tag group by dragging tags from the Available Tags list to the tag group name in the Tag Groups list. Note that this does not remove the tags from the Available Tags list; they remain available for adding to other tag groups.
- Change the order of tags in a tag group by dragging them up or down with in the tag group.
- Hide or show the tags in a group in the Tag Groups list by clicking the triangle to the left of the tag group’s name.

The Tag Groups dialog may be left open while you work and positioned out of the way or on a second display, so it is always available to manage your tags. Changes you make to the order of tags in a tag group are reflected instantly in any open matrix views or image viewer windows that are displaying images by tag.

Tag groups are stored in session files, so you should save a session by choosing Save Session from the File menu if you want to use the same tag groups in a future Tecplot Chorus session.
3 - 5 Scatter Plots

Tecplot Chorus provides both 2D and 3D scatter plots. To open a new scatter plot, choose New 2D Scatter Plot or New 3D Scatter Plot from the View menu, or click or in the toolbar.

Scatter plots are useful to visualize trends and correlations between two or more variables. On a scatter plot, each case appears as a single scatter symbol. Its position represents two (or three, in the case of a 3D plot) variables, and its color—and in a 3D plot, its size—can represent an additional variable or two.

2D scatter plots are useful for comparing two main variables. For example, it can reveal a relationship between an independent and dependent variable, or correlations between two dependent variables. 2D scatter plots can also be used for visualization of constraints.

3D scatter plots are typically used in situations where two variables (which appear on the X and Y axes) affect, or are correlated with, the result of a third (which appears on the Z axis). The 3D scatter plot can be rotated interactively to reveal details that may not be apparent from all angles (see Section 3 - 5.3 “Zooming, Translating, and Rotating Scatter Plots”).
Exploring Your Results

Scatter plots may be saved as a PNG (Portable Network Graphics) file by right-clicking the plot and choosing Save Plot as Image from the context menu, or by clicking the Save Plot as Image button in the plot’s sidebar. The saved image is the same size as the version of the plot displayed on the screen.

**3 - 5.1 Scatter Plot Properties**

If the Properties panel is not visible, open it by choosing View > Properties. This sidebar may be docked to any edge of the Tecplot Chorus window, combined with the Filters sidebar, or dragged out of the Tecplot Chorus window entirely and positioned as desired on any display.

**2D Scatter Plot Properties**

- **General** - Sets general options for the plot.
  - X-Axis, Y-Axis - Choose the variables to be used for the X and Y axes. The values of the selected variables will be used to position the scatter symbols on the plot.
  - Axis Details - Click to open the Axis Details dialog and specify range and grid spacing for each axis. See Section 3 - 7 “Setting Axis Details”.
- **Coloring** - Choose the color for the scatter symbols. You may choose a single, solid color, to have the scatter symbol color chosen automatically based on the value of a variable, or to have filter violations displayed in a special color.
  - Solid Color - All cases are displayed in the single color you choose using the drop-down color menu. Click the ... color tile to create your own color using a color mixer.
  - Color By Variable - Cases are colored based on the value of a variable. You may also optionally display a legend indicating the colors that correspond to the values of the selected variable.
  - Color By Filter Violations - All cases are displayed regardless of filter settings. However, the symbols representing the cases are color-coded to indicate which filters apply to them (see Constraint Visualization with 2D Scatter Plots).
  - Show Legend - If coloring by variable, activate the checkbox to display a color legend in the plot. Click Legend Labels to set the range and number of steps for the labels in the legend using the Color Legend dialog (see Section 3 - 5.2 “Color Legend Dialog”).
- **Symbol - Size** - Choose the size for the scatter symbols.
Constraint Visualization with 2D Scatter Plots

When you set a 2D scatter plot to be colored by filter violations, you enable the visualization of constraints in your plot. Filters on dependent and independent variables no longer hide cases, but rather affect the color of the symbols representing the individual cases. (Filters on other variables continue to hide cases, as usual.) The legend, shown at the upper right of the plot below, can be toggled on or off in the Coloring section of the Properties panel. A shaded area further highlights the cases that fall outside the filter values set for the axis variables.

In this example, the filters have been set to exclude cases by Mach No. and Alpha (the shaded area, with the individual cases shown in gray because they also violate a filter on an independent variable) and also to exclude certain other cases by their lift and drag coefficients. These cases are displayed in blue (for cases that only violate one of the lift and drag constraints) or red (for cases that violate both the lift and drag constraints).

If an additional filter were added on another independent variable (such as Beta), additional cases could change to gray outside the shaded area, since their Mach No. and Alpha variables might still fall inside the white (unconstrained) area.
3D Scatter Plot Properties

The Properties panel for 3D scatter plots is divided into four sections: General, Coloring, Symbol, and Surrogate Model. We will not consider the Surrogate Model section here. For more information on surrogate models, see Chapter 5: "Surrogate Models".

- **General** - Sets general options for the plot.
  - **X-Axis, Y-Axis, Z-Axis** - Choose the variables to be used for the X, Y, and Z axes. The value of the selected variables will be used to position the scatter symbols.
  - **Axis Details** - Click to open the Axis Details dialog and specify range and grid spacing for each axis. See Section 3.7 "Setting Axis Details".

- **Coloring** - Choose the color for the scatter symbols. You may choose a single, solid color, or to have the scatter symbol color chosen automatically based on the value of a variable.
  - **Solid Color** - All cases are displayed in the single color you choose using the drop-down color menu. Click the ... color tile to create your own color using a color mixer.
  - **Color By Variable** - Cases are colored based on the value of a variable. You may also optionally display a legend indicating the colors that correspond to the values of the selected variable.
  - **Show Legend** - If coloring by variable, activate the checkbox to display a color legend in the plot. Click Legend Labels to set the range and number of steps for the labels in the legend using the Color Legend dialog (see Section 3.5.2 "Color Legend Dialog").

- **Symbol** - Sets the symbol size and shape.
  - **Size** - Choose the size for the scatter symbols. You may choose a constant size, or to have the size determined by the value of a variable.
  - **Shape** - Choose a sphere or a cube.

### 3 - 5.2 Color Legend Dialog

The Color Legend dialog allows you to specify the approximate number of labels in the legend and the range represented by the legend.

- **Approximate Number of Labels** - The approximate number of labels in the legend. The number of labels you see in your legend may not be exactly the number you enter here; more labels may be used to make the ranges "nicer."
- **Legend Range** - Using the radio buttons, you may choose to use the minimum and maximum values of the variable selected for "Color By," or manually enter a custom range.
3 - 5.3 Zooming, Translating, and Rotating Scatter Plots

The following tools, which you will find on the Tecplot Chorus toolbar, can be used to zoom, translate (move), and rotate your scatter plot.

- **Moves the plot.** With a 2D plot, the axes stay in the same location and the values represented on the axes change, showing you a different part of your data. With a 3D plot, the entire plot, axes and all, moves within the window.
- **Zooms the plot.** When this tool is active in a 3D scatter plot, moving the mouse up and down while holding down the mouse button zooms the plot in and out, respectively. In a 2D scatter plot, use the mouse to draw a rectangle around a group of points to zoom in on them.

You can also zoom the plot at any time (without switching to the Zoom tool) by moving the wheel on your mouse, if it has one.

- **Rotates the plot.** Hold down the mouse button and move the mouse to rotate.

Only 3D scatter plots may be rotated.

To reset the view back to the default, undoing all zooming and translation (but not rotation), choose View > Reset.

3 - 5.4 Selecting Cases in a Scatter Plot

Each symbol in a scatter plot represents one case. You can select cases using the tool, then perform operations on the selected cases.

- Click a symbol to select a single case. All other cases are de-selected.
- To toggle the status of individual cases without affecting other cases, click single symbols while holding the Control key.
- To select a group of cases, drag a rectangle around them using the mouse. All cases that fall inside the rectangle are selected; all others are de-selected.
- To select multiple groups of cases, hold the Control key while dragging a rectangle around the second and subsequent groups of cases.

Cases selected in any plot or view are selected in all open views and plots.

After selecting cases in the plot, click the right mouse button on the selection to view or create images or data for a case. See Chapter 4: “Analyzing Individual Cases” for further details on these operations.

The right-click menu also lets you designate the selected cases as active or inactive, which sets the internal variable Case Status accordingly. Filter on Case Status to display only active or inactive cases.
Exploring Your Results

3 - 6 Line and Symbol Plots

To open a new line or symbol plot, choose View > New Line Plot, or click in the toolbar.

Line plots are often used to visualize how an input (independent variable) affects an output (dependent variable). They are especially useful for comparing magnitude of change between one data point and the next. Adjacent points are always connected by straight lines, making any deviations from an expected progression immediately obvious.

The line plot can display symbols at each data point in addition to, or instead of, lines between them. Symbols-only mode is often used when the values being displayed are discrete rather than continuous, such as in this plot showing the number of iterations a solution requires to converge for each Mach value simulated.

Line and symbol plots may be saved as a PNG (Portable Network Graphics) file by right-clicking the plot and choosing Save Plot as Image from the context menu, or by clicking the Save Plot as Image button in the plot's sidebar. The saved image is the same size as the on-screen version of the plot.
3 - 6.1 Zooming and Translating Line and Symbol Plots

The following tools, which you will find on the Tecplot Chorus toolbar, can be used to translate (move) and rotate your line or symbol plot. To reset the view back to the default, undoing all zooming and translation, choose View > Reset.

- Translate tool; moves the plot. The axes stay in the same location and the values represented on the axes change, showing you a different portion of your data.
- Draw a rectangle to zoom in on that portion of the plot.

You can also zoom the plot at any time (without switching to the Zoom tool) by moving the wheel on your mouse, if it has one.

3 - 6.2 Line and Symbol Plot Properties

If the Properties panel is not visible, open it by choosing View > Properties. This panel may be docked to any edge of the Tecplot Chorus window, combined with the Filters sidebar, or dragged out of the Tecplot Chorus window entirely and positioned as desired on any display.

The Properties panel for a line or symbol plot is divided into four sections: General, Coloring, Symbol, and Surrogate Model. We will not consider the Surrogate Model section here. For more information on surrogate models, see Chapter 5: “Surrogate Models”.

Using the Color and Symbol settings, it is possible to group cases by the discrete values of up to two variables and represent them by either unique colors or symbols.

- **General** - Sets general options for the plot.
  - X-Axis, Y-Axis - Choose the variables to be used for the X and Y axes.
  - Axis Details - Click to open the Axis Details dialog and specify range and grid spacing for each axis. See Section 3 - 7 “Setting Axis Details”.
  - Sort By - The cases are drawn in order from the lowest to highest value of the variable selected here. Usually an independent variable (often the X-axis variable in the plot).
  - Show Legend - A checkbox that shows or hides a legend of line colors corresponding to values of the current Sort By variable.
  - Show Lines - Choose to include lines in the plot. (The visibility of symbols is controlled using the Shape drop-down menu in the Symbol section.)
- **Color** - Sets the color grouping.
  - Solid Color - The lines or symbols are all given a single color.
  - By Variable - Groups discrete values of the chosen variable together and draws these cases separately using a different color for each value. The colors assigned to each value appear in the legend, if shown.
- **Symbol** - Sets the symbol grouping, size, and shape.
Exploring Your Results

- **Shape** - Selects a static symbol shape and does not group on a variable. Choose the desired symbol shape. Set to None to hide symbols entirely.
- **By Variable** - Groups discrete values of the chosen variable together and draws these cases separately using a different symbol shape for each value. The symbol shapes assigned to each value appear in the legend, if shown.
- **Size** - Choose the desired static symbol size.

### 3 - 6.3 Selecting Cases in a Line or Symbol Plot

You can select cases using the tool, then perform operations on the selected cases. This is simplest to do if symbols are displayed, as the actual data points are not always obvious when only lines are displayed. (The Lines & Symbols plot mode is often useful here.)

- Click near a case to select the case. Any other selected cases are de-selected.
- To select a group of cases, draw a rectangle around them using the mouse. All cases that fall inside the rectangle are selected; all others are de-selected. It may be useful to have a table view open to confirm that you have selected the desired cases.
- To select multiple groups of cases, hold the Control key while drawing a rectangle around the second and subsequent groups of cases.

Cases selected in any view or plot are selected in all open views and plots.

After selecting cases in the plot, click the right mouse button on the selection to view or create images or data for a case. See Chapter 4: “Analyzing Individual Cases” for further details on these operations.

The right-click menu also lets you designate the selected cases as active or inactive, which sets the internal variable Case Status accordingly. Filter on Case Status to display only active or inactive cases.

### 3 - 7 Setting Axis Details

By default, Tecplot Chorus uses the minimum and maximum values of the variable assigned to an axis as that axis’s range, and automatically determines the spacing of the grid. These settings can be adjusted for each plot by clicking the Axis Details button in the plot’s Properties sidebar.

The dialog has a page for each axis in the plot. Shown here is the Axis Details dialog for a 2D Scatter Plot, which has two axes. The 3D Scatter Plot has three tabs, since it has three axes. The contents of each tab are the same.

- **Axis Range** - Enter custom min/max values for the axis. The defaults are the minimum and maximum values of the axis variable.
- **Grid Spacing** - Allow Tecplot Chorus to automatically determine the grid spacing, or manually enter a custom spacing value. Not available for 3D Scatter Plots.
- **Reset All Axis Ranges** - Resets the range settings for all axes to the default values (the minimum and maximum values of the variable assigned to the axis).
Table Views

A Table view is a simple spreadsheet-like listing of the values of each variable for every case in the project. To open a new Table view, choose View > New Table View or click the button in the toolbar. Rows represent cases and columns represent variables. You can scroll the table horizontally or vertically if necessary to see all the data in the project, and sort by the value of any variable by clicking a column header. (Clicking the same column header again reverses the sort order.) Drag the column headers to rearrange the display order of the variables; this is saved in the session file.

3 - 8.1 Constraint Visualization with Table Views

Cases listed in the Table view incorporate indicators that show how the displayed cases relate to the filters. Some of these indicators are most useful with Range filters (see Section 3 - 2 "Filters" for a tour of the types of filters). The indicators are:

- Shading along the left and/or right edges of the cell indicates the proportion of the minimum/maximum values of the filter to the variable's range. In the example here, the Mach Number filter (a Range filter) is set to exclude about the lowest 20% and the highest 40% of values. Therefore, about the left 20% and the right 40% of the Mach Number column is shaded.

- A small, gray downward-pointing tick mark at the top of each cell indicates the position of the cell's value in the variable's range. The lowest value has this tick mark placed at the left of the cell, and the highest has it at the right. Other values have the tick mark placed proportionally.

- Values that violate the filter are colored red; values that pass the filter are colored black. In the example here, the Case ID is subject to a single-value filter, and this value is set to 3, which is...
Exploring Your Results

the only black value in the Case ID column. You can also see that all the visible values in the Mach ID column are being filtered out, as they are red.

3 - 8.2 Selecting Cases in a Table View

You can select single or multiple cases in the table, then perform operations on them.

- To select a single case, click a row. All other rows are automatically de-selected.
- To toggle the status of individual cases without affecting other cases, click each row while holding the Control key.
- To select a contiguous range of rows, click the first row in the range, then click the last row in the range while holding the Shift key.
- You may select multiple contiguous ranges of rows. Select the first range as above, then select the second and subsequent ranges by holding Control while clicking the first row in the range, and Control + Shift while clicking the last row in the range.
- Press Control-A to select all cases.

Cases selected in any view or plot are selected in all open views and plots.

After selecting cases in the table, click the right mouse button on the selection to view or create images or data for the selected cases. See Chapter 4: “Analyzing Individual Cases” for further details on these operations.

The right-click menu also lets you designate the selected cases as active or inactive, which sets the internal variable Case Status accordingly. Filter on Case Status to display only active or inactive cases.

3 - 8.3 Editing Values

To edit the value of a variable for a particular case, double-click the cell containing the value to be edited. Type the new value and press Enter.

3 - 8.4 Deleting Variables

To delete a variable from your project, right-click the variable’s column header in the table view and choose Delete Variable from the context menu. All types of variables may be deleted; however, the variable Case ID may not be deleted, as it is used internally by Tecplot Chorus.

Deleting a variable affects data views, calculated variables, filters, and surrogate models that display or use the variable. Some of the results may be surprising. For example, if the variable you delete is being used in a filter, deleting the variable may cause additional cases to appear in your data views and plots, since the filter no longer applies.

3 - 8.5 Deleting Cases

To delete one or more cases from your project, select the cases to be deleted, then right-click the selection and choose Delete from the context menu.
3 - 8.6 Table View Properties

If the Properties sidebar is not visible, open it by choosing View > Properties. This sidebar may be docked to any edge of the Tecplot Chorus window, combined with the Filters sidebar, or dragged out of the Tecplot Chorus window entirely and positioned as desired on any display.

- **Use Filters** - Normally, the Table view displays all cases, even if filters are active. To also filter the Table view, activate the Use Filters checkbox. See Section 3 - 2 "Filters" for more information on using filters.

3 - 8.7 Selected Cases Sidebar

The Selected Cases sidebar is a Table view that displays information about only the cases selected in other views. Remember that, in Tecplot Chorus, selection is generally independent of view. Cases you select in one view are selected in every view.

Like any sidebar, the Selected Cases sidebar can be docked to any edge of the Tecplot Chorus workspace; initially, it appears docked at the bottom of the window. Also like any sidebar, it can be “torn off” and dragged out of the main workspace and positioned on any display.

All functions of Table views, except for filtering, can be used with the Selected Cases sidebar, including sorting, rearranging columns, editing values, and deleting cases or variables.

Selecting cases in the Selected Cases sidebar will select these cases in other views, but the cases shown in the sidebar will not change. To change the cases shown in the sidebar, select the cases in another view.
Exploring Your Results

3 - 8.8 Constraint Visualization with the Selected Cases Sidebar

As with the Table view, cases listed in the Selected Cases sidebar incorporate indicators that show how the displayed cases relate to the filters. Some of these indicators are most useful with Range filters (see Section 3 - 2 “Filters” for a tour of the types of filters).

The indicators are:

- Shading along the left and/or right edges of the cell indicates the proportion of the minimum/maximum values of the filter to the variable’s range.
  
  In the example here, the Mach Number filter (a Range filter) is set to exclude about the lowest 20% and the highest 40% of values. Therefore, about the left 20% and the right 40% of the Mach Number column is shaded.

- A small, gray downward-pointing tick mark at the top of each cell indicates the position of the cell’s value in the variable’s range. The lowest value has this tick mark placed at the left of the cell, and the highest has it at the right. Other values have the tick mark placed proportionally.

- Values that violate the filter are colored red; values that pass the filter are colored black. In the example here, the Case ID is subject to a single-value filter and this value is set to 3, which is the only black value in the Case ID column. You can also see that all the visible values in the Mach ID column are being filtered out, as they are red.
Analyzing Individual Cases

Once you have located cases of interest in your project, Tecplot Chorus lets you view images or data associated with them. Supported image formats open directly in Tecplot Chorus, while supported data files (such as Tecplot layouts) open in Tecplot 360 EX.

In Tecplot 360 EX, you can create a style sheet from a single case and use it as a template to generate new images for other cases. These images are then available in your Tecplot Chorus project.

4 - 1 Viewing Images

JPEG or PNG Images associated with one or more cases can be viewed by selecting the cases, right-clicking them, and choosing View Images from the context menu.

A new image viewer window appears.
Analyzing Individual Cases

If you have selected a single case, all images associated with that case initially appear in the image viewer. If you have selected multiple cases, the image viewer initially shows an image from each selected case that has images under the default tag. (See Section 1 - 1.2 “Tagging Image and Data Files” for more about tags.)

4 - 1.1 Image Viewer Controls

- **Zoom** - The zoom slider at the bottom of the window makes the individual images larger or smaller.

4 - 1.2 Image Viewer Properties

The following controls appear in the Properties panel when an image viewer window is active.

- **Show Labels** - Activate the checkbox to label each displayed image with variable values from its case. Click **Select Labels** to choose the variables to be shown using the Label Images dialog. The Label Images dialog also appears automatically the first time you activate the Show Labels checkbox.
- **Tag Groups** - Opens the Tag Groups dialog to allow you to create and modify tag groups. See “Tag Groups” on page 39.
- **Show Images with Tags** - Choose which images to display for each case by choosing the tag or tag group. You may choose multiple image tags or groups by holding Shift or Control while clicking items in the list to toggle the state of individual tags or to select contiguous ranges of items. If you select a single tag, all selected cases will display the associated images having that tag next to each other, wrapping to new rows to fit the window. If you select multiple tags, including a tag group containing more than one tag, the images will be arranged in a grid; cases are rows and tags are columns. See Section 1 - 1.2 “Tagging Image and Data Files” for more details about tags.
- **Accumulate Cases When Selecting** - If this checkbox is marked, you can add cases to this image viewer by selecting them in any Tecplot Chorus view (for example, a table or matrix view) or plot. Only cases not already shown in the image viewer are added. The images displayed depend on the tags selected in the image viewer’s Show Images with Tags list.

To remove cases from the image viewer, select the image or images to be removed, then right-click and choose **Remove Cases from View** from the context menu. All images associated with that case are removed from the image viewer. (This applies only in the current image viewer.)

- **Selected Image Values** - Displays the values of all variables from the cases associated with the selected images in a scrollable table.

If multiple cases are selected, the text “(Multiple values)” appears next to any variable that does not have the same value in all selected cases.
- **Diff From Current** - Displays images highlighting the differences between the current image and the others in the window (see “Showing Image Differences” on page 55).
4 - 1.3 Removing Cases from the View

To remove cases from the image viewer, select an image associated with the case or cases to be removed, then right-click and choose Remove Cases from View from the context menu. All images associated with that case are removed from the image viewer. The deletion applies only to the current image viewer; no cases or images are deleted from your project.

4 - 1.4 Exporting Images

You may export selected images from the viewer, or copy one to the clipboard, by right-clicking and choosing Export Image or Copy to Clipboard from the context menu. Any labels enabled in the Properties panel are included in the image.

When exporting, the Export Images dialog appears.

- **Filename** - The directory where the file will be placed. If you are exporting a single image, you can also enter the filename here. If you are exporting multiple images, you specify only a directory and Tecplot Chorus names the files. Click Browse to specify this using a Save dialog.
- **Image Width** - The width of the exported image in pixels. The height is determined by the image's aspect ratio. Mark the Use Original Image Width checkbox to use the original image dimensions.

Exported images are saved in PNG (Portable Network Graphics) image files.

4 - 1.5 Showing Image Differences

To display the differences between one image and others in the image viewer:

1. Click the master image (the image to which other images will be compared),
2. Click the Diff From Current button at the bottom of the sidebar.
Analyzing Individual Cases

If multiple image tags are being displayed, the image you select in Step 1 above determines the tag of all images used for the differences.

A new window appears displaying the differences between the master image and all other images. Images should be the same size and be derived from identical plot styling. Otherwise, the differences displayed may be due to these factors rather than to differences in the solution data.

The master image is displayed in the first column. Each additional column has two rows: an original image from the image viewer at the top, and a difference image (derived from each image and the master image) immediately below it.

Difference images are created by a bitwise exclusive-or (XOR) of each image with the master image. This process leaves pixels that are the same in both images black. The result is then inverted so that the background is white again. Colors change in ways that tend to make them stand out from the background.

The Properties sidebar displays the values of all variables from the cases associated with the selected images in a scrollable table. If multiple cases are selected, the text “(Multiple values)” appears next to any variable that does not have the same value in all selected cases.

4 - 2 Viewing Data

Auxiliary data files associated with cases may be viewed in Tecplot 360 EX by selecting the cases, right-clicking them, and choosing View Data from the context menu. We refer to this capability as a “deep dive.”

Out of the box, Tecplot Chorus supports loading these file types in Tecplot 360 EX using View Data:

- Tecplot Data (.dat, .plt, .szplt, plus nonstandard extensions .bin and .arc as synonyms for .plt)
- Tecplot Layout (.lay) and Layout Package (.lpk)
- CGNS (.cgns, .adf)
- PLOT3D (.g, *.g, .x, *x, .xyz, *xyz, .in, *.in, .q, *.q, f, *.f, fun, *.fun, *.nam)
Viewing Data

- EnSight (.case)
- TRIX (.trix)
- OpenFOAM (controldict)
- Fluent (.cas, .dat as well as gzipped versions of these)

Support for additional formats can be added with a little text editing. See Appendix A: “Loading Other Data Formats” for more information.

Once the data has been loaded, you can use Tecplot 360 EX to prepare publication-quality plots, compare data from two or more cases, perform various kinds of analyses, and save templates that can be applied to create additional images for your cases.

As with images, each data file associated with a case has a tag, which was assigned when the project was imported into Tecplot Chorus. (See Section 1 - 1.2 “Tagging Image and Data Files.”) Most types of data files allow multiple files to be associated with a given tag and loaded into Tecplot 360 EX in a single step.

The Select Data dialog lets you choose the tag of the desired data file or files. If multiple cases are selected, only the tags common to all selected cases are available in the View Data dialog. If the selected cases have no data file tags in common, you will receive an error message instead. Selected cases must have data files with at least one tag in common.

Tecplot Chorus attempts to automatically determine what loader should be used to open the data. If there is only one suitable option, Tecplot Chorus will not allow you to change the loader setting. If more than one loader can be used to open the data, or if an available loader supports more than one configuration, choose the desired loader and option set in this dialog. (See Appendix A: “Loading Other Data Formats” for more information on loader descriptions.)

After you choose the tag of the data files to be opened, and optionally the method to be used to load the data, choose the macro and the style template to be applied to the file. Click Browse to open a template stored on disk, or choose a recently-used template from the menu.

- A macro (.mcr file) is a file containing instructions to perform a series of actions in Tecplot 360 EX. A macro can perform virtually any operation that Tecplot 360 EX can perform interactively, such as slicing, adding streamtraces, calculating new variables, and so on. You can record a macro file in Tecplot 360 EX’s Scripting Menu and apply it to any data file you open from Tecplot Chorus.
- A style template (.sty file) is a file containing information about the visual appearance of a single case in Tecplot 360 EX. You can create a style template using the Chorus sidebar inside Tecplot 360 EX.

If you have not created any templates yet, or if you wish to use a default view, choose None.
Analyzing Individual Cases

Click OK to open Tecplot 360 EX and display each selected case’s data in its own frame.

A powerful post-processing tool is now available to you to further investigate the actual data from your cases. The Chorus sidebar appears docked to the right of the Tecplot 360 EX workspace.
4 - 2.1 The Chorus Sidebar

The Chorus sidebar provides integration between Tecplot Chorus and Tecplot 360 EX. Like all sidebars in both products, it can be snapped to any edge of the workspace, docked with other sidebars, or undocked from the main Tecplot 360 EX window and positioned as desired. If you accidentally close the sidebar, you can re-open it by choosing View > Chorus while in Tecplot 360 EX.

The Chorus sidebar has the following functions:

- **View Page** - When you choose to view data in Tecplot Chorus and Tecplot 360 EX is already open, a new page is created, rather than opening a new instance of Tecplot 360 EX each time. This saves memory and time. You can choose which page you wish to view from this scrolling list, or delete the selected page by clicking the **Delete current page** button.

Data files that appear on pages that are not currently visible may still use memory. Tecplot 360 EX will load data only as it is needed for display, but if you are working with large data files or have limited resources, you may experience poor performance with multiple pages open. If this happens, close pages that you do not currently need.

- **Label Frames** - Determines how the frames are labeled, similar to the Show Labels feature when viewing images in Tecplot Chorus (see Section 4 - 1.1 “Image Viewer Controls”).
  - Click a variable to display that variable’s value in each frame.
  - Hold the Control key while clicking a variable to toggle its selection state. This can be used to select additional variables or to turn off the display of variables you don’t want.
  - To select a contiguous range of variables, click the first variable in the range, then, while holding the Shift key, click the last variable in the range. To select additional contiguous ranges, hold Control while performing this maneuver. Alternatively, you can click and drag the mouse to select a range of values.

- **Save As Style Template** - Click **Save as Template** to save the appearance of the current frame (that is, all style information) in the Tecplot Chorus project for later application to other cases. A Save dialog appears to allow you to save the file. Name the file as you like and click **Save**.

- **Show diff Data** - Allows you to display differences between cases, if multiple cases are open.
Analyzing Individual Cases

First, click the frame containing the master case (the case to which you wish to compare other cases) and click **Set Frame as Master**. Then activate the Show Diff Data checkbox.

![Image of frame settings](image)

Similar to the image comparison feature in Tecplot Chorus proper (see Section 4.1.5 “Showing Image Differences”), the master is shown on the left. Each additional column shows one case’s original data and, below it, a difference frame calculated between that case and the master case.

Unlike image comparison, this is a comparison of the actual underlying data. You may want to use different styling on the difference frames to better reveal this.

- **Synchronize styles** - Click **Synchronize Styles** to copy all style information from the current frame to all other frames. This is how, for example, you can move the frame label on all frames: simply move it in one frame, then synchronize styles.

### 4 - 3 Creating Images

You can have Tecplot Chorus generate new images for some or all of the cases in your project, based on the original data file associated with them. You may wish to do this if you do not already generate images.
Creating Images

using a post-processing step, or you may want to produce additional images to better visualize details that have only become apparent after a "deep dive" into selected cases (see Section 4-2 "Viewing Data").

The data files used to create new images must be in formats that can be opened for viewing in Tecplot 360 EX from within Tecplot Chorus. See "Viewing Data" on page 56 for a list of the formats supported by Tecplot Chorus out of the box, or Appendix A: "Loading Other Data Formats" if your data is in another format.

To create these new images, Tecplot 360 EX applies a style template to each case's data file to determine the appearance of the image. To create a style template:
1. View a typical case as described in Section 4-2 "Viewing Data".
2. Zoom, rotate, and style your plot as desired.
3. In the Chorus sidebar, click Save as Template and save the new style template.

Once you have created a style template, you may apply this template to any or all cases in your project to generate new images as follows:

1. Select the cases for which you want to generate new images.
   The exact procedure varies based on what type of view or plot in which you select the cases; see Chapter 3: "Exploring Your Results" for detailed instructions for each view.
2. Right-click the selection and choose Create Images from the context menu. The Create Images dialog appears.

   In the Create Images dialog, specify:
   • Data Source - The tag of the data file that will be used to generate the image. (See Section 1-1.2 "Tagging Image and Data Files" for more about tags.)
   • Loader - Choose the Tecplot 360 EX loader (and optionally the loader settings) to be used to load this data. If only one loader is suitable, or if the data is in a native Tecplot format, Tecplot Chorus chooses it for you automatically. (See Appendix A: "Loading Other Data Formats" for more information on loaders.)
   • Macro - A Tecplot macro (.mcr file) that will be run before the style template is applied to each data file. Click Browse to choose the macro file or pick a recently-used macro from the menu.
   • Style template - The Tecplot style template (.sty file) that should be applied to each data file to produce a styled image. Click Browse to choose the style file or choose a recently-used template from the menu.
   • Width - The desired width of the image in pixels. (The height will be calculated automatically based on the aspect ratio of the plot frame.)

To generate new images for all cases in your project, open a table view and press Control-A to select all cases.
Analyzing Individual Cases

- Tag - The tag by which this type of image will be known in Tecplot Chorus when choosing to view images. (See Section 1 - 1.2 “Tagging Image and Data Files”.)

Tecplot Chorus begins creating image files for the selected cases in the background.

For data files whose locations are specified by relative paths, Tecplot Chorus writes the image files it generates to folders it maintains inside your project root folder (check Project > Set Root Path). If your project root is on a network volume, make sure that all users who will be generating data files with Tecplot Chorus have the proper permissions for creating folders and files in this directory hierarchy.

For data files specified using absolute paths, the generated image files are written in the same directory as the data file they were generated from.

Click the Manage Jobs button in the status bar to see this background task in the Manage Jobs window.

The status messages displayed include:
- In Progress - Tecplot Chorus is currently processing the job.
- Ready - Tecplot Chorus has finished processing the job and results from all cases are ready to be deposited.
- Failed - An error occurred during the processing of the job and no results were produced.
- Partial - Errors prevented some cases from being processed, but others were processed successfully and are ready to be deposited. The status message indicates how many cases were processed successfully and how many failed.

When a job’s status is Ready or Partial, select it in the list and click the Deposit button to import the images, data files, or extracted variables to the project. Tecplot Chorus then starts a wizard to append the new data to the project (see Section 2 - 4 “Appending To a Project”).
4 - 4 Creating Data Files

Besides images, Tecplot Chorus can create layout packages (.lpk files) for selected cases. A layout package is a Tecplot data file that specifies a default style and view along with the subset of the original data set required to reproduce the current view in Tecplot 360 EX. For example, zones and variables that are not visible are omitted from the .lpk file. Layout packages are an ideal format for sharing interactive views of your data (rather than static images) with colleagues.

The procedure for creating layout files is very similar to that described in Section 4 - 3 “Creating Images” for creating images; review that section for details. First, open a typical data file in Tecplot 360 EX and create a style template (see Section 4 - 2.1 “The Chorus Sidebar”). Then select the cases for which you want to generate layout packages, right-click them, and choose Create Data from the context menu.

If the selected cases have more than one data file, you will need to choose a data file tag to act as a source for the layout packages. Then you’ll enter a name for the generated file, assign it a tag so it can be accessed in Tecplot Chorus (see Section 1 - 1.2 “Tagging Image and Data Files”), and select the style template you created. You may optionally choose a loader if the default loader setting is not appropriate and also choose a Tecplot macro file to be run after each file is loaded. (See Appendix A: “Loading Other Data Formats” for more information on loaders.)

Tecplot Chorus processes the job in the background. Click the Manage Jobs button in the status bar to see the job’s status in the Manage Jobs window and, when it has finished, deposit the complete or partial results in your project.

Tecplot Chorus then starts the wizard to append the new files to the project (see Section 2 - 4 “Appending To a Project”).

4 - 5 Extracting Variables from Data Files

Tecplot 360 EX supports loading metadata from your model results in Tecplot format, as well as from selected third-party formats. Tecplot 360 EX can also perform additional analysis and save the results as metadata (see Chapter 21 in the Tecplot 360 EX User’s Manual).

By calling on Tecplot 360 EX, Tecplot Chorus can load the metadata from your results as variables in a project. Tecplot Chorus can also be directed to use Tecplot 360 EX’s analysis capabilities to calculate additional values.

To extract variables:

1. Select the cases for which you want to extract variables.
Analyzing Individual Cases

The exact procedure varies based on the type of view or plot in which you select the cases; see Chapter 3: “Exploring Your Results” for detailed instructions for each view.

To extract variables for all cases in your project, open a table view and press Control-A to select all cases.

2. Right-click the selection and choose Extract Variables from the context menu. The Extract Variables dialog appears.

In the Extract Variables dialog, specify:
- **Data Source** - The tag for the data file from which variables are to be extracted.
- **Loader** - If the data file is not in Tecplot format, choose the loader that will be used to load it.
- **Macro** - This may be a macro file, previously written or recorded with Tecplot 360 EX, that extracts the desired data using tools on the Analyze menu. Tecplot 360 EX will run this macro file for each case that is loaded and pass the analysis results to Tecplot Chorus, where they will be inserted into your project. Choose None if your solver provides the variables you wish to extract.

See the next section, Recording an Analysis Macro, for instructions on recording a macro file in Tecplot 360 EX for use with the Extract Variables feature.

3. Click **OK**. Tecplot Chorus begins extracting the variables from the selected data files in the background. When this process is complete, it will be counted as “Ready” in the status bar. Click the **Manage Jobs** button to deposit the results in your project.

4 - 5.1 Recording an Analysis Macro

To record a macro for use with the Extract Variables feature:

1. Launch Tecplot 360 EX.
2. In Tecplot 360 EX, load a data file typical of your cases.
3. Choose Scripting > Record Macro and save the new macro file with an .mcr extension. The Macro Recorder window appears.
4. Perform the desired analysis using the tools on the Tecplot 360 EX Analyze menu. You may perform as many different operations as you like; the results of each operation will be picked up when Tecplot Chorus extracts the variables from each case in your projects. However, if you perform the same operation more than once, only the last results from that calculation will be available.
5. Click **Stop Recording** in the Macro Recorder window.
4 - 6 Custom Actions

You can extend Tecplot Chorus to allow you to perform other actions on selected cases. Two sample custom actions are included with Tecplot Chorus.

- **Extract Data with Tecplot 360 EX** - Executes a Tecplot 360 EX macro that extracts a slice from each selected data file and writes the slice data to its own file. A link to this file is then added to your Tecplot Chorus project. This action may be modified to invoke other macro files for other purposes.

  After extraction has finished, click **Manage Jobs** at the bottom of the Tecplot Chorus window, select the job, and click **Deposit**.

- **Open with Paraview** - Opens a data file associated with the first selected case using the open-source Paraview data visualization tool.

When enabled, custom actions appear on the context menu when you right-click selected cases in any view or plot. See Appendix B: “Actions” for more information on this feature.
Surrogate Models

A surrogate model is a simplified proxy for the CFD model underlying your results. Using an existing (often sparse) result set, the surrogate model predicts results for cases that you have not run. You can then query the surrogate model and visualize its response via line plots or 3D scatter plots.

Essentially an n-dimensional curve fit, the surrogate model is derived from the implicit correlations between inputs and outputs for the cases you’ve already simulated, rather than being calculated by a physics model. For this reason, generating a surrogate model takes much less time than running even a single additional CFD simulation—usually a few seconds to a few minutes, depending on the number of existing cases, the type of model used, and your workstation’s performance.

Although a surrogate model is necessarily an approximation, it’s a convenient tool to help you to make sense of your results. It’s especially useful for highly-dimensional CFD projects, in which full exploration of the design space might require thousands or even millions of multi-hour simulation cases. A surrogate model can help you:

- **Identify potential outliers** - The surrogate model can quickly reveal cases that do not fall in line with extrapolations based on cases you’ve already simulated.
- **Simplify your CFD model** - If the surrogate model is flat for a particular input variable, that variable may have limited impact on the results and can potentially be eliminated from the experiment, reducing dimensionality, saving simulation time, and making your results easier to visualize.
- **Fail faster** - If, for example, after running a few cases on a proposed airfoil design, the surrogate model unexpectedly suggests that no combination of design parameters within the physical capabilities of the materials can achieve the desired lift, you can investigate immediately with a few well-chosen simulations, then potentially reject the design entirely if it can never meet requirements.
- **Nail down boundary conditions** - If the surrogate model hints at a sudden change in output for small changes in input, you can run a few cases near the predicted boundary to find the critical parameter values more precisely.
- **Optimize designs faster** - The surrogate model can suggest the general region of the design space where the best performance (such as the highest lift) might be found. Additional cases in that region will refine the surrogate model further and further, helping you find the best design parameters with fewer time-consuming simulations than might otherwise be required.
Surrogate Models

5 - 1 Getting Started with Surrogate Models
Working with a surrogate model in Tecplot Chorus typically involves the following steps.

- Define variable natures. The surrogate model detects correlations between inputs and outputs, so Tecplot Chorus must know which variables in your project are independent and which are dependent before you can train a surrogate model.
  
  If you didn't specify variable natures when creating your project, you can use the Change Variable Nature dialog, accessible via Project > Change Variable Nature. See Section 2 - 6. “Changing Variable Nature” for more details.

- Train the model. Specify which independent variables you wish to use as inputs to the surrogate model (see Section 5 - 2.1 “Training the Model”).

- Create a line plot or 3D scatter plot employing appropriate variables.
  
  - In line plots, one or two independent variables may be used. If one independent variable is used on an axis, a second may optionally be used as the Group Data By variable. If both axes use dependent variables, one independent variable may be used as the Sort By variable, and either a second independent variable or None may be used for Group Data By. See Section 5 - 3 “Surrogate Model in Line Plots”.
  
  - In 3D scatter plots, exactly two independent variables must be used, either as axes (typically X and Y) or to determine the size and color of the scatter symbols. See “Surrogate Model in 3D Scatter Plots” on page 72.

  All other variables used in the plot must be dependent variables for which you want to see the surrogate model's estimate.

- Display the surrogate model on your plot. Tick the Show checkbox in the Surrogate Model section of the plot's Properties sidebar. The Show checkbox is disabled until the model has been trained and a plot with appropriate variable assignments has been created.

- Optionally, refine the query values. You can tell Tecplot Chorus exactly what values of each input variable should be given to the surrogate model in order to calculate a response. For input variables not being used in the plot, you may specify a single value; see Section 5 - 5 “Setting the Evaluation Point”. For other inputs, you can specify multiple values; see Section 5 - 6 “Setting Range and Sampling”.

At this point, you should be able to see the surrogate model response on your plot as either a line or surface. You can now refine the plot by rotating, zooming, and adjusting its properties, then save it using the plot context menu. You may also export the derived data (the surrogate model's output); see Exporting Derived Data from a Line Plot or Exporting Derived Data from a 3D Scatter Plot as appropriate.

5 - 1.1 Minimum Number of Cases
The more variables you specify as inputs, the more cases you will need in your project to train a surrogate model so that it is capable of making useful predictions. The minimum number of cases required depends on the number of parameters to be incorporated and on the type of model.

Quadratic response surfaces have a mathematical limit based on the number of input variables used. This type of model requires a number of data points equal to the number of terms in the quadratic polynomial that describes the surface. For a 6-parameter model, this polynomial has 28 terms. So 28 is the minimum number of cases you will need to generate a quadratic response surface for six parameters, with the caveat that no case may have any parameter values in common with other cases. As the number of inputs to the model increases, the number of cases required increases geometrically.

Kriging-based models do not technically require any minimum number of cases, but in general, fewer than 20-30 cases will produce poor results, and you may need up to 100 to start with for best results, especially when using many independent variables.

1. 6 quadratic terms, 15 cross terms with pairs of parameters, 6 linear terms, and a constant term
If you have a very limited number of cases, you can still generate useful surrogate models by limiting the number of inputs to be considered. However, the more cases you have, the better the surrogate model will serve to predict outputs, and the more inputs the model can realistically take into account.

5 - 2 Using a Surrogate Model

In Tecplot Chorus, the surrogate model may be shown in line plots and in 3D scatter plots. For these plot types, a Surrogate Model section appears in the Properties sidebar containing the controls you will need to train and visualize the model. (The Properties panel shown here is for 3D scatter plots.)

Tecplot Chorus supports a single surrogate model; the same model is used in all plots. However, different variables may be chosen in each plot to visualize different aspects of the model. The range of the input variables and how their values are sampled may also differ among plots.

5 - 2.1 Training the Model

In the training process, you specify the independent variables (inputs or parameters) to consider, and Tecplot Chorus generates a surrogate model based on correlations between these variables and the dependent variables (outputs or results) in your project.

You train your model via the Surrogate Model Training dialog, which can be accessed from the sidebar for the Line Plot or 3D Scatter Plot by clicking the Training button, or by choosing Surrogate Model > Training from the menu bar.

This dialog allows you to choose the type of surrogate model to be generated and to specify the independent variables (inputs or parameters) to be considered by the surrogate model.

- **Type of model**: Choose Kriging or Quadratic Response Surface.
  - **Kriging**: A statistical interpolation that yields the best linear unbiased prediction of values between cases using a covariance model (variogram). The more computationally intensive of the two methods, but may produce better results with smaller numbers of cases. A kriging-based model is guaranteed to touch all actual data points (although this may not always be obvious in plots) but may not be as smooth as the alternative.
Surrogate Models

- **Quadratic response surface** - A simpler least-squares approximation using a second-degree polynomial. A good fit for CFD and other physics applications, as many physical phenomena are at most quadratic. Faster than kriging and generally sufficient for getting “the lay of the land” when the number of cases is too large to wait for kriging.

- **Independent variables** - Choose the independent variables to be used in your surrogate model.
  - Click a variable in the left column, then click **Add >**, to move it to the right column and into the surrogate model.
  - Click a variable in the right column, then click **< Remove**, to move it to the left column and out of the surrogate model.

You may select multiple variables in either column by holding Control or Shift while clicking, making it easier to add or remove multiple variables from the model. Press Control-A to select all variables in a column.

Click **OK** to train the surrogate model with the variables you have chosen. Depending on the number of cases in your project, the number of variables included in the model, the model’s type, and your workstation’s performance, this may take anywhere from a few seconds to a few minutes.

A single surrogate model can be active at any one time; the model you create in the Surrogate Model Training dialog is queried to generate the response that may be shown in open Line Plot and 3D Scatter Plot windows. Each of these windows can, however, show the model's response for a different combination of independent and dependent variables. You can also choose different query values for the input variables in each plot (see “Setting Range and Sampling” on page 74).

5 - 3 **Surrogate Model in Line Plots**

To display surrogate model results on a line plot, the plot must be set up in one the two following ways:

- An independent variable on one axis and a dependent variable on the other.
- Dependent variables on both axes and one independent variable as Sort By.

Often the X axis will be used for an independent variable and the Y axis for a dependent variable. (See “Line and Symbol Plot Properties” on page 47 for details on choosing these variables.)
The Properties panel for Line Plots includes the Surrogate Model section, in which the following options are available.

- **Training** - Displays the Surrogate Model Training dialog, described in Section 5 - 2.1 “Training the Model”, where you can change the type of surrogate model to generate and the parameters to be included in the model.

- **Show** - Activate this checkbox to see the surrogate model’s prediction on the plot, based on the values of the independent variable used as an axis or as the Sort By variable. This checkbox is available only after you have trained a surrogate model and chosen appropriate variables as described above.

The response of the surrogate model is displayed as one or more dashed lines. Dashed lines are used even if the plot is set to use symbols or symbols and lines for the actual case values. If multiple lines are shown on the plot (due to the plot’s Sort By setting), multiple dashed lines are shown. The color of each dashed line matches the color of the corresponding solid line representing your actual results.

It may take a moment to query the model and display the result, and the model needs to be requeried when the plot’s variables are changed. When you are not actively using the surrogate model, turn off this checkbox to avoid these delays. If the wait is excessive, you might consider querying the model at fewer points by **Setting Range and Sampling**.

- **Evaluation Point** - Opens a dialog (see Section 5 - 5 “Setting the Evaluation Point”) to specify the query value for the independent variables being used in the surrogate model that are not being used on the plot.

- **Range and Sampling** - Opens a dialog (see Section 5 - 6 “Setting Range and Sampling”) to choose ranges and the number of query values to use for the independent variable(s) used in the plot.

At the bottom of the panel is an R-squared coefficient of determination indicating the goodness of fit of the surrogate model to the actual data for the dependent variable(s) currently displayed on the plot. The closer R-squared is to 1.0, the better the fit is.

### 5 - 3.1 Exporting Derived Data from a Line Plot

To export the values calculated by a surrogate model as a CSV file, the surrogate model response must be visible on the plot. Right-click the plot and choose Export Derived Data from the context menu. A Save dialog appears to let you name the file and choose the folder where it will be saved.

The exported file normally includes results for an evenly-spaced distribution of the independent variable’s range (or the actual values when the independent variable is the Sort By variable). Other input variables are, by default, queried at the minimum value found in the project for that variable.

Often, you will want to export derived data for points that are not in the project to answer questions like “what does the surrogate model predict that the lift coefficient would be at with a value of Alpha for which I have not run a simulation?” The Range and Sampling dialog (see Section 5 - 6 “Setting Range and Sampling”) can be used to override the default query values for the plot’s independent variable. The Evaluation Point dialog (see Section 5 - 5 “Setting the Evaluation Point”) can be used to change the query value for other independent variables.
5 - 4 Surrogate Model in 3D Scatter Plots

To display surrogate model results on a 3D scatter plot, the plot must employ exactly two independent variables. These variables can be used either on two of the three axes, or as the Color By and Size variables. Often the X and Y axes are used for independent variables, and the Z axis for an independent variable, as shown above. (See “3D Scatter Plot Properties” on page 44 for details on choosing these variables.)

The Properties panel for 3D Scatter Plots includes the Surrogate Model section, in which the following options are available.

- **Training** - Displays the Surrogate Model Training dialog, described in Section 5 - 2.1 “Training the Model”, where you can change the type of surrogate model to generate and the parameters to include in the model.
- **Show** - Activate this checkbox to visualize the surrogate model's prediction for the dependent variable on the plot, based on the values of the two independent variables. This checkbox is available only after you have trained a surrogate model and assigned appropriate variables as described above. The surrogate model's response is displayed as a translucent blue surface in the plot by default (both the color and the translucency can be changed).
  It may take a moment to query the model and display the result, and the model needs to be re-queried when the plot's variables are changed. When you are not actively using the surrogate model, turn off this checkbox to avoid these delays. If the wait is excessive, you might consider querying the model at fewer points by Setting Range and Sampling.
- **Evaluation Point** - Opens a dialog (see Section 5 - 5 “Setting the Evaluation Point”) to optionally specify a single value for each independent variable being used as input to the surrogate model but not being used in the plot.
- **Range and Sampling** - Opens a dialog (see Section 5 - 6 “Setting Range and Sampling”) to choose ranges and the number of query values to use for each independent variable.
Setting the Evaluation Point

- **Color** - Choose the color for the surface representing the derived data by picking a swatch. Choose the ... color swatch to select any color using a standard color picker dialog.
- **Translucency** - Choose the level of translucency for the surrogate model surface using the slider. 0 is opaque and 100 is fully transparent. You may also enter a numeric value directly, or use the small arrow buttons to fine-tune the value.

At the bottom of the panel is an R-squared coefficient of determination indicating the goodness of fit of the surrogate model to the actual data for the displayed dependent variable(s). The closer R-squared is to 1.0, the better the fit is.

5 - 4.1 Exporting Derived Data from a 3D Scatter Plot

To export the values calculated by a surrogate model as a CSV file, the surrogate model must be active. Right-click the plot and choose Export Derived Data from the context menu. A Save dialog appears to let you name the file and choose the folder where it will be saved.

The exported file normally includes results for an even distribution of query values along the axes (if the independent variables are being used in the plot's axes) or the actual values in the project (if the independent variables are being used to size and color the scatter symbols). Other input variables are, by default, queried at their minimum project value.

Often, you will want to export derived data for values that are not in the project to answer questions like "what does the surrogate model predict that the lift coefficient would be at a combination of Mach, Alpha, and Beta for which I have not run a simulation?" The Range and Sampling button (see Section 5 - 6 "Setting Range and Sampling") and the Evaluation Point button (see Section 5 - 5 "Setting the Evaluation Point") can be used to override the values of the inputs to the model.

5 - 4.2 Exporting Surface Coefficients from a 3D Scatter Plot

Right-click a 3D scatter plot while a response surface surrogate model is active and choose Export Surface Coefficients from the context menu to produce a text file showing how the model calculates the dependent variable value. This file may be viewed in any text editor, such as Notepad.exe on Windows. An example of this file is shown below.

```
Independent Variables
V1 = Alpha
V2 = Beta
V3 = Mach

Equation for dependent variable: Drag
Result = 575164 + 2021.56*V1 + -145.074*V1**2 + 9443.39*V2 + -213.566*V2**2 + -2.33378e+006*V3 + 2.54697e+006*V3**2 + 466.728*V1*V2 + -14425.1*V1*V3 + -15397.4*V2*V3
```

5 - 5 Setting the Evaluation Point

For each independent variable that is used as an input to the surrogate model, but which is not being used on the plot, the default query value of that variable is the lowest value of the variable available in your project at the time of model training.

If an independent variable is being used on a plot, multiple values for that variable are used for surrogate model queries. See Section 5 - 6 "Setting Range and Sampling".

To change this behavior, click the Evaluation Point button in the Surrogate Model section of the plot's Properties sidebar, or choose Surrogate Model > Evaluation Point from the menu bar. The Surrogate Model Evaluation Point dialog appears. (If you have not yet trained a model, the Surrogate Model Training dialog appears first.)
The Surrogate Model Evaluation Point dialog allows you to choose a single value for each input being considered by the model.

Use the slider to select the query value to be used for each variable, or enter a value directly in the text field. The slider respects the minimum and maximum values shown, but you may enter a number outside this range in the text field.

The specified evaluation point is global, and applies to all plots in which the surrogate model is shown. These values are also used when generating derived data (see Exporting Derived Data from a Line Plot and Exporting Derived Data from a 3D Scatter Plot).

5 - 5.1 Setting the Evaluation Point from a Selected Case

To choose a case's variable values for the surrogate model, right-click a case in any view or plot, then choose Set Surrogate Model Evaluation Point from the context menu. The Surrogate Model Evaluation Point dialog opens with the selected case's values filled in for all independent variables used in the model. The new values are applied immediately to all open plots that are currently displaying a surrogate model response. You can then, if desired, fine-tune the values using the sliders and fields in the dialog.

The selected case may not be used as the evaluation point if it has null or NaN values for any model input variable.

5 - 6 Setting Range and Sampling

To calculate a response curve or surface, Tecplot Chorus normally uses query values of the independent variables used in the plot according to the following rules:

<table>
<thead>
<tr>
<th>Where the variable is used</th>
<th>Default range and sampling</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plot axis</td>
<td>Even distribution within the axis range</td>
</tr>
<tr>
<td>Group Data By (in Line Plots)</td>
<td>The actual values of the variable found in the project</td>
</tr>
<tr>
<td>Sort By (in Line Plots)</td>
<td>Even distribution between the minimum and maximum values found in the project</td>
</tr>
<tr>
<td>Color By (in 3D Plots)</td>
<td></td>
</tr>
<tr>
<td>Size (in 3D Plots)</td>
<td></td>
</tr>
</tbody>
</table>

The same query values are used when exporting derived data.

If a variable is not being used in a plot, but is an input to the surrogate model, these rules do not apply. Instead, the evaluation point determines the variable’s query value. See Section 5 - 5 "Setting the Evaluation Point".

You can change these behaviors by specifying your own range and sampling instructions for the plot's independent variables. The specified values are then used as the values of the associated variable when querying the model. You can use this feature both to limit the extent of the surrogate model response shown on the plot and to choose the query values for exports.
Click the **Range and Sampling** button in the Surrogate Model section of a Line Plot's or 3D Scatter Plot's Properties panel. The Surrogate Model Range and Sampling dialog appears.

The Surrogate Model Range and Sampling dialog allows you to specify ranges for model input variables used in the active plot as well as how many query values will be distributed across each range. Either one or two variables are displayed depending on whether the active plot is a line plot or a 3D scatter plot. Mark the User Defined checkbox next to the variable of interest and specify values as a comma-separated list of exact values and/or ranges.

A range is specified in the format `first-last:samples`; that is, the first value in the range, followed by a hyphen, followed by the last value in the range, followed by a colon, followed by the number of equally-spaced samples to take from the range. The range is inclusive of the specified first and last values. For example, `0-1:11` specifies the eleven values 0.0, 0.1, 0.2, 0.3, 0.4, 0.5, 0.6, 0.7, 0.8, 0.9, and 1.0.

Single values and ranges may be combined in any order. For example, `5, 6, 7, 8, 10-15:6, 20-25:6` specifies the values 5, 6, 7, 8, 10, 11, 12, 13, 14, 15, 20, 21, 22, 23, 24, and 25.

The line or surface displayed in your plot, which represents the surrogate model's response, respects the minimum and maximum of the values specified in this dialog. The model is queried at the exact points specified (for 3D plots, all combinations of the points specified when the independent variables are being used as axes), both for drawing the model's response on plots and for exporting derived data; see Section 5.3.1 “Exporting Derived Data from a Line Plot” and Section 5.4.1 “Exporting Derived Data from a 3D Scatter Plot”.
Surrogate Models
Appendices
Loading Other Data Formats

Tecplot Chorus uses Tecplot 360 EX for examining solution data from selected cases. This visualization tool seamlessly opens native Tecplot-format data files, including .plt (binary data), .szplt (subzone data), .dat (ASCII data), .lay (layout) and .lpk (layout package) files. It also recognizes the nonstandard filename extensions .bin and .i, used by some solvers, as synonyms for .plt files.

Tecplot 360 EX also includes a suite of data loader add-ons that can open data files in many other popular CFD formats, including CGNS, EnSight, FEA, FLOW-3D, Fluent, Kiva, and PLOT3D.

Loading these files from inside Tecplot Chorus requires a loader description file that identifies the filename extensions to which it applies and specifies the options required for the loader to successfully load your data files. Loader descriptions are stored in a special directory in your Tecplot Chorus installation folder, namely interop/360/loaderdescriptions.

Some data formats, such as Fluent and PLOT3D, use two physical files per data set, one for the coordinates and one for the rest of the variables. In this case, you must give both files the same tag when adding them to the project so that Tecplot Chorus will know they should be opened together when you view the case’s data.

Loader description files for the following formats are included with Tecplot Chorus. If necessary, you may modify these description files to set the options you usually use to load your data files.

- CGNS (.cgns, .adf)
- EnSight (.case)
- TRIX (.trix)
- OpenFOAM (controlDict)
- Fluent (.cas, .dat as well as gzipped versions of these)

If you need to load another format, one of these files can be used as a template for creating your own loader description. See Chapter 4 of the Tecplot 360 EX User’s Manual for more information on these formats.
A - 1 Editing a Loader Description

The CGNS loader description file, cgns.xml, is shown here. This file may be viewed and edited in any text editor, such as Notepad on Windows.

```xml
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!DOCTYPE ChorusForeignLoaderDescription>
<ChorusForeignLoaderDescription version="1">
  <TecplotLoader Name="CGNS Loader">
    <StandardSyntaxIdentifier Name="FILELIST_CGNSFILES" DefaultExtension=".cgns"/>
    <InstructionTemplate Name="CGNS" StandardSyntax="1.0" FILELIST_CGNSFILES="AverageToNodes" "No" "AveragingMethod" "Arithmetic" "SectionLoad" "SeparateZones" "LoadBCs" ="Yes" AssignStrandIDs ="Yes" LOADCONVERGENCEHISTORY ="No">
      "STANDARDSYNTAX"
    </InstructionTemplate>
  </TecplotLoader>
</ChorusForeignLoaderDescription>
```

The section between `<InstructionTemplate Name="CGNSstd">` and `<InstructionTemplate>` defines a macro instruction that invokes the CGNS loader for the specified file (indicated using the placeholder %FILELIST_CGNSFILES%). The easiest way to change this is to record a macro file in Tecplot 360 EX, use the Tecplot 360 EX dialogs to specify loader options, and extract the READDATASET instruction from the macro using a text editor:

1. Start Tecplot 360 EX, either by choosing to view a case's data in a Tecplot Chorus project or directly. To start Tecplot 360 EX without Tecplot Chorus:
   - In Windows, click the Tecplot 360 EX shortcut on the Start menu.
   - In Linux, `cd /path/to/tecplot360/bin ; ./tec360`
2. In Tecplot 360 EX, choose Scripting > Record Macro to begin recording the macro and specify a name for it and a directory to save it in.
3. Choose File > Load Data File(s) and load a data file from one of your cases. Be sure to specify any loader options necessary to load the file correctly. This action is recorded to the macro file.
4. Click the Stop Recording button in the Macro Recorder dialog.

Open the recorded macro file in a text editor and find the `!READDATASET` instruction. Beginning with the text "STANDARDSYNTAX", but excluding the text `!READDATASET`, copy the entire instruction into the loader description file between the tags `<InstructionTemplate Name="CGNSstd">` and `<InstructionTemplate>`. Do not include the single quotes around the instruction. Also do not include the DATASETREADER line.

Replace the path of the file that appears in the macro instruction with the placeholder text `FILELIST_CGNSFILES`. Tecplot Chorus will replace this with the path of the actual file being loaded when you choose to view or extract a case's data.

A - 2 Creating Other Loader Descriptions

A loader description can be used as a template for loading other data formats supported by Tecplot 360 EX. Copy the file and give it a new name. You will need the set of options, specific to each loader, necessary to load one of your typical files in that format.

The easiest way to get this information is to record a macro that loads a single data file as described in the previous section. The body of the $!READDATASET instruction (excluding the single quotes, the $!READDATASET instruction and the DATASETREADER line) should be placed between the `<InstructionTemplate Name="...">` and `<InstructionTemplate>` tags.

References to the loader name and any filename extensions should be changed as appropriate for the new loader, and the `<TecplotLoader Name="...">` tag should be edited to include the name of the loader as...
Multiple Instruction Templates

found in the DATASETREADER line of the recorded macro file. Save the new file in the folder interop/360/
loaderscriptions as a plain text file with an .xml extension.

We are interested to hear about what kinds of data files you are using so that we can improve the loader
descriptions included with Tecplot Chorus. Please do not hesitate to contact Technical Support if you need
help creating your own loader description.

A - 3 Multiple Instruction Templates

If you frequently load data files of a single type but with varying sets of options, it is possible to include
multiple instruction templates in a loader description file. Simply copy the text beginning with
<InstructionTemplate> and ending with </InstructionTemplate> and paste it above or below any existing
instruction template definition, then change the loader options as desired, either manually or by recording
a macro as already described. Change the Name attribute in the <InstructionTemplate> tag to change how
this set of options appears in Tecplot Chorus dialogs.

A - 4 XML Schema

The following are the tags supported in loader description files.

<table>
<thead>
<tr>
<th>Tag</th>
<th>Notes</th>
<th>Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChorusForeignLoaderDescription</td>
<td>Encloses one or more TecplotLoaders.</td>
<td>Yes</td>
</tr>
<tr>
<td>Version=</td>
<td>File version.</td>
<td>No</td>
</tr>
<tr>
<td>TecplotLoader</td>
<td>Block containing loader descriptions for a given Tecplot Loader.</td>
<td>Yes</td>
</tr>
<tr>
<td>Name=</td>
<td>Official “ADDONID” loader name.</td>
<td>Yes</td>
</tr>
<tr>
<td>StandardSyntaxIdentifier</td>
<td>Name of File or Dir list identifier found in the STANDARDSYNTAX string along with the associated default file extension.</td>
<td>Yes</td>
</tr>
<tr>
<td>Name=</td>
<td>Name of the standard syntax identifier.</td>
<td>Yes</td>
</tr>
<tr>
<td>DefaultExtension=</td>
<td>Default extension for the identifier.</td>
<td>Yes</td>
</tr>
<tr>
<td>InstructionTemplate</td>
<td>Custom loader instruction.</td>
<td>Yes</td>
</tr>
<tr>
<td>Name=</td>
<td>Name of custom loader instruction.</td>
<td>Yes</td>
</tr>
<tr>
<td>(body)</td>
<td>STANDARDSYNTAX instruction string with placeholders for actual files to deliver.</td>
<td>Yes</td>
</tr>
</tbody>
</table>

A - 5 Alternative Method

Loader description files work only for the CGNS, EnSight, FEA, FLOW-3D, Fluent, Kiva, and PLOT3D
loaders. These loaders all use a standard macro syntax that Tecplot Chorus knows about and can generate
as needed to load data files. However, an alternative method is available that will work with all loaders,
including the loaders just listed as well as all others included with Tecplot 360 EX.

In this method, you create a macro file that contains the instructions necessary to read a single data file. A
copy of this macro file is then placed in each folder that contains a non-Tecplot data file. The same macro
file can be used for all cases; a copy can be inserted into the appropriate folder as a post-processing step in
your solver workflow. This macro file, rather than the actual data file, is then tagged as part of your
Loading Other Data Formats

Tecplot Chorus project. When you view data for a case, instead of loading the data file directly, Tecplot 360 EX loads and executes the macro, which loads the data file.

For this technique to work, the raw data files must have the same file name in every case. If you have more than one non-Tecplot format data file you wish to load, or if the names vary, you will need to prepare a separate macro file for each.

For example, suppose you have the following folder structure:

```
--- a1
  |-- sample_nozzle.g
  |-- sample_nozzle.q
  `-- a2
    |-- sample_nozzle.g
    |-- sample_nozzle.q
```

In other words, two case folders, a1 and a2, each containing a pair of PLOT3D files (the .g and .q files). You will create a sample_nozzle.mcr file, a Tecplot macro that loads the PLOT3D files, and deposit a copy in each case folder. The resulting structure will look like this:

```
--- a1
  |-- sample_nozzle.g
  |-- sample_nozzle.mcr
  |-- sample_nozzle.q
  `-- a2
    |-- sample_nozzle.g
    |-- sample_nozzle.mcr
    |-- sample_nozzle.q
```

The sample_nozzle.mcr file would be the file tagged in Tecplot Chorus as an auxiliary data file for the case.

A - 5.1 Creating the Macro File

**Step 1 Record the Macro**

1. Start Tecplot 360 EX, either by choosing to view a case's data in a Tecplot Chorus project or directly. To start Tecplot 360 EX without Tecplot Chorus:
   - In Windows, click the Tecplot 360 EX shortcut on the Start menu.
   - In Linux, `cd /path/to/tecplot360/bin ; ./tec360`
2. In Tecplot 360 EX, choose Scripting > Record Macro to begin recording the macro and specify a name for it and a directory to save it in.
3. Choose File > Load Data File(s) and load a data file from one of your cases. Be sure to specify any loader options necessary to load the file correctly. This action is recorded to the macro file.
4. Click the Stop Recording button in the Macro Recorder dialog.

If you make a mistake, simply stop recording and start over with a fresh macro file.

**Step 2 Edit the Macro**

The next step is to edit the macro so that it does not mention specific directory names in any $!READDATASET command(s) it contains. This may be done with any standard text editor, such as Notepad on Windows. Any directory names found in the macro must be replaced with the variable $[MACROFILEPATH]. This way, the macro loads the data file from the directory it is placed in, rather than from the location of the data file you opened when recording the macro.
Alternative Method

For example, your recorded macro file might contain the following line:

```plaintext
$!READDATASET "STANDARDSYNTAX" "1.0" "FILELIST_GRIDFILES" "1"
"/users/joe/myproject/a1/sample_nozzle.g" ...
```

(The actual command will likely be much longer, as it will contain specifications of every loader option.)

The text `/users/joe/myproject/a1/sample_nozzle.g` is the path to the file you loaded. This must be edited so that it looks like this (note the slash after the vertical bar):

```plaintext
$!READDATASET "STANDARDSYNTAX" "1.0" "FILELIST_GRIDFILES" "1"
"[MACROFILEPATH]/sample_nozzle.g" ...
```

The macro file may contain other references to files, since many data formats use multiple files. Each of these must be edited in a similar fashion so that the macro loads the files from whatever directory the `.mcr` file is placed in.

Save the `.mcr` file after making these edits.

**Step 3  Copy the Macro File to Each Case Folder**

This can be done as a post-processing step after your solver has created a data file, if desired. If you do only a few cases at a time, you may find it easier to just make the copies manually.

**Step 4  Tag the Macro File**

Now you must tag the macro file in Tecplot Chorus to make it available as a data file. This can be done when the project is initially created (see Section 2 - 3 “Creating Projects” on page 18), or it can be done afterward (see Section 2 - 4 “Appending To a Project” on page 28).

- If you are using the Delimited Text Reader, add a column to the file that names the `.mcr` file (the same file name for each case, `sample_nozzle.mcr` in our example). There is no need to include columns for the actual data files (for example, `.g` and `.q` files).
- If you are using the File Crawler, on the Files to Link page you should specify a pattern that matches only the `.mcr` file (for example, `sample_nozzle.mcr`). Do not use any patterns that match the actual data files (`.g` and `.q` files in our example).

In either case, specify a tag that represents the file's contents (such as “Sample Nozzle”) so you can easily find it in Tecplot Chorus.

**A - 5.2  Viewing The Data Files**

Once you have set up the macro files properly and tagged them in Tecplot Chorus, you can view these data files in the same way you view any other data file. Tecplot Chorus will tell Tecplot 360 EX to open the macro file, which will load the data. See Section 4 - 2 “Viewing Data” on page 56 for instructions.
Loading Other Data Formats
**Actions**

Actions are custom operations that appear on the context menu when you right-click selected cases in a Tecplot Chorus project. Two sample actions are included with Tecplot Chorus:

- **Extract Data with Tecplot 360 EX** - Executes a macro that extracts a slice from a data file associated with each case and writes the slice data to its own file. A link to this file is then added to your Tecplot Chorus project. This action may be modified to invoke other macro files for other purposes.
  
  After extraction has finished, click **Manage Jobs** at the bottom of the Tecplot Chorus window, select the job, and click **Deposit**.

- **Open with Paraview** - Opens a data file associated with the first selected case using the third-party Paraview data visualization tool.

The example actions run Python scripts. You will need Python 2.6.x or 2.7.x installed on your computer to use them.

**B - 1 Enabling the Example Actions**

The example actions are stored in the folder `interop/actions`, which is in the Tecplot Chorus installation folder. This folder also contains a registration file, a simple XML file that tells Tecplot Chorus how each action should appear in the context menu and the command line necessary to invoke it.

Tecplot Chorus supports multiple registration files; all `.xml` files in the `interop/actions` folder are scanned for action definitions. The file `examples.xml` is the registration file for the example actions. You will need to modify this file to enable the example actions, as they are turned off initially.

Tecplot Chorus will also scan a folder in your home directory for action registration files. This may be useful if you don’t have write access in the program installation directory, or if you want certain actions to be available only to certain users. On Windows, this folder is `Tecplot/Chorus/interop/actions` in your My Documents folder. On Linux, this folder is `~/.tecplot/chorus/interop/actions`. You’ll need to create this folder if it does not exist.

You may want to copy `examples.xml` (and other action registration files) to this folder and modify it there so it will be used by future versions of Tecplot Chorus you install without needing to copy it to the new version’s `interop/actions` directory.
Open examples.xml in a text editor and find the `<action>` tags, which initially read `action enabled="false">`. Change one or both of these to read `action enabled="true">`. The line immediately following the `<action>` tag includes a `<name>` tag that identifies the action you’re editing.

The `<exec>` tag for each action includes placeholder text that must be edited before the actions will work on your computer. In particular:

- Replace `/path/to/python` with the path of your Python interpreter. On Linux systems, this is usually `/usr/bin/python`. On Windows systems, this is usually `C:/Python26/python.exe`. If an appropriate Python interpreter is in your system’s PATH, you may simply use `python`.
- Replace `/path/to/ExtractDataWithTecplot360.py` or `/path/to/OpenWithParaview.py` with the full paths to these scripts. On Windows, these files are usually in `C:/Program Files/Tecplot/Tecplot Chorus 2019 R1/interop/actions`.

The text `%INSTRUCTION_FILE%` will be used by Tecplot Chorus when the action is invoked. Do not change it.

After enabling one or both of the custom actions, close Tecplot Chorus if it is open, then restart it and open a project. When you right-click selected cases in any data view or plot, the enabled actions will be shown in the context menu, as seen here. However, the actions won’t run until you make the changes described in the next section.

**B - 2 Configuring the Example Actions**

The example Python scripts must be modified before they will run on your computer. Open them in a text editor and make the indicated changes.

**B - 2.1 ExtractDataWithTecplot360.py**

Search for the following placeholders and replace them as noted.

- Replace `/path/to/resulting/data/datafile.plt` with the path where the generated Tecplot 360 EX data file (.plt file) will be temporarily stored before being added to the project.
- Replace `/path/to/tecplot360/bin/tec360` with the path to the Tecplot 360 EX executable. On Windows systems, this is usually `C:/Program Files/Tecplot/Tecplot 360 EX 2019 R1/bin/tec360.exe`.
- Replace `/path/to/extract_slice.mcr` with the path to the Tecplot 360 EX macro to be run, i.e., `extract_slice.mcr`.

**B - 2.2 OpenWithParaview.py**

Search for the placeholder `/path/to/paraview` and replace it with the complete path of the Paraview executable on your system.

Windows users should use forward slashes (`/`) in pathnames rather than backslashes (`\`).
Creating Your Own Actions

As this feature is new, there may be changes to how actions work in future releases of Tecplot Chorus.

If you can program in Python, the example Python scripts and Tecplot macros can be used as starting points for developing your own actions.

Tecplot Chorus actions can, however, be written in virtually any language. While we used Python for the examples, you could use Perl or Ruby, or Java or C#—even C or C++. If you can use it to write programs that can be run from the command line, you can use it to write a Tecplot Chorus action. (An XML library is handy, too.)

Actions work according to the following process:

- The user invokes the action by selecting one or more cases, right-clicking, and choosing the action from the context menu.
- Tecplot Chorus writes an instruction XML file. The instruction file contains information about the project, the job, and the selected cases.
- Your action is launched, passing the path to the instruction file as an argument to your action according to the command line template given in the \texttt{<exec>\text{tag}} in the action registration file.
- Your action reads and parses the instruction file.
- Using information gleaned from the instruction file, your action script performs its work.
- If your action needs to add any variables or file links to the project, it must perform the following steps:
  - Write its results to a CSV file in the pending jobs folder specified by the instruction XML file. The name of the results must be \texttt{job#.csv} where \texttt{#} is replaced with the job ID from the instruction XML. The first column must be the Case ID for the affected cases. Additional columns may be used to overwrite variables already in the project for the indicated cases or to add new variables.
    - Only one or more successfully processed cases should be written to this CSV file. The number of successfully processed cases may be less than the number of cases passed to the action. If no cases were successfully processed, do not create the CSV file. Tecplot Chorus uses the presence or absence of this file to determine the status displayed in the Manage Jobs dialog.
  - Write a status message to \texttt{job#.runstatus} in the pending jobs folder (again, \texttt{#} is replaced with the job ID). This text is displayed when the user clicks the \texttt{Job Details} button in the Manage Jobs dialog.
  - Finally, create \texttt{job#.done} (where \texttt{#} is once more replaced with the job ID) in the pending jobs folder to signal to Tecplot Chorus that it has finished its work.
    - The user then deposits the action's results into their project using the Manage Jobs window.
  - If the action does not need to add any data to the project, for example for a viewer action such as the Paraview example action, it should simply delete the instruction file to signal to Tecplot Chorus that the action has been completed.

As this feature is new, there may be changes to how actions work in future releases of Tecplot Chorus.
Actions

The provided Python utility library, `JobInfo.py`, helps you manage this flow if you are writing your action in Python. Make sure a copy is in the same folder as your action, or in some other folder that Python will look in for modules, such as your Python installation’s `site-packages` directory.

After writing your script, tell Tecplot Chorus how to invoke your action by creating a registration file for it. We suggest copying `examples.xml` to a different name and modifying it as appropriate. A single registration file may contain definitions of multiple custom actions; simply include as many `<action>` ... </action> sections as required.

Your action’s registration file should be placed in the `interop/actions` directory in your Tecplot Chorus installation folder, or in the user-specific action folders appropriate to your operating system:

- **Windows** - Tecplot/Chorus/interop/actions in My Documents
- **Linux** - ~/.tecplot/chorus/interop/actions.
Configuration

Most Tecplot Chorus configuration options are set and stored for individual projects, not for the whole application. This Appendix documents useful global settings for Tecplot Chorus. On Windows, these settings are stored in the registry under the key \HKEY_CURRENT_USER\Software\Tecplot\Chorus. On Linux, they are stored in a text file under the user home directory, ~/.config/Tecplot/Chorus.conf.

C - 1  ImageListViewStylesheet, ImageTableViewStylesheet

The default background color of image views is a light gray, but this may be modified via the ImageListViewStylesheet and ImageTableViewStylesheet configuration settings.

These values are Qt color specifications, which are essentially the same as CSS color specifications. Most commonly you will use a color name (lightgray is the default) or a 3- or 6-digit hexadecimal RGB color specification beginning with #. See http://qt-project.org/doc/qt-4.8/qcolor.html#setNamedColor for details.

- Windows - Use RegEdit to add or modify these String (REG_SZ) values under the key \HKEY_CURRENT_USER\Software\Tecplot\Chorus or, from the Windows command line, issue the commands:
  reg add HKCU\Software\Tecplot\Chorus\ /v ImageListViewStylesheet /t REG_SZ /f /d lightgray
  reg add HKCU\Software\Tecplot\Chorus\ /v ImageTableViewStylesheet /t REG_SZ /f /d lightgray

  Replace the lightgray at the end of each command line with the desired color specification.

- Linux - Open Chorus.conf in your text editor and find the line beginning with ImageListViewStylesheet and/or ImageTableViewStylesheet and change the color specification following the = sign as desired.

  If no such line(s) exist, add them just below the [General] line. If there is no [General] line in the file, add one as the first line of the file, then add the desired background color assignment(s) below that.
Configuration
License Management

D - 1 Entering Your License

The first time you launch Tecplot Chorus after a fresh installation, you will be prompted to enter your license information:
License Management

You will also see this dialog if Tecplot Chorus cannot validate your license information (for example, because your evaluation license has expired, or because the network license server is not available). Additionally, you may change your license information at any time from the Help menu.

SYSTEM ADMINISTRATORS

Tecplot products store their license configuration file in a platform-specific location. Each Tecplot product has its own license configuration file.
Windows: C:\Users\<username>\AppData\Local\Tecplot
Linux: ~/.local/share/data/tecplot

The above directories are specific to the individual workstation users.
If you want all users of the computer to use the same license configuration for a given Tecplot product, you may move the license configuration file to the product installation directory after initial license setup.
To prevent users from editing the license configuration, you may then change the permissions on the license file to be writable only by an administrator or root user.

How you install your license information depends on what type of license you have.

- If you wish to evaluate the product before purchasing, you may obtain an Evaluation license with a single click. See Evaluation License Setup.
- If you have an Activation Code for a Single-User license and have Internet access, you enter the activation code. See Single-User License Setup Using An Activation Code.
- If you have a License File for a Single-User license, you select the license file. See Single-User License Setup Using A License File.
- If you have a Network license, you specify the server name and port number of the RLM license server on your network. See Network License Setup.
- If you have a License File for a Single-User license, you select the license file. See Single-User License Setup Using A License File.
D - 1.1 Evaluation License Setup

To obtain a time-limited evaluation license key so you can try the product before purchasing, make sure the “Evaluation” license type is selected in the Licensing dialog, then click Begin Evaluation. The product evaluation period begins. You will see a notice on the product’s Welcome Screen indicating when your evaluation license will expire.

This procedure requires an active Internet connection. If for some reason you cannot fully evaluate Tecplot Chorus on an Internet-connected computer, or if you need additional time to complete your evaluation, contact Tecplot Support for a time-limited single-user license file, which may then be installed using the instructions in “Single-User License Setup Using A License File” on page 94.

D - 1.2 Single-User License Setup Using An Activation Code

If you received an activation code for your product, allowing it to be activated over the Internet, follow the instructions below. If you received a license key file, or if the workstation you have installed the product on does not have Internet access, see “Single-User License Setup Using A License File” on page 94.

To activate the product, simply enter or paste your activation code in the field provided. Then click Activate.
License Management

The license key corresponding to your activation code is downloaded to your computer, and Tecplot Chorus uses that license.

D - 1.3 Single-User License Setup Using A License File

You will need the license file sent to you by Tecplot as an e-mail attachment. Please save it to a file on your computer in an easy-to-find location, such as the Desktop.

If you do not have your license file, or have lost it, click Request License in the Licensing dialog for instructions on how to obtain it.

1. Make sure the “License File” option is selected in the Licensing dialog.
2. Click Open License File. A file browser appears. Select the license file e-mailed to you, then click Open.
   Alternatively, you can Copy and Paste the contents of the license file to the available field.
   The message “Status: Valid” appears in the Current License Information panel at the upper right.
3. Click OK to save the license information.

Tecplot Chorus now uses the chosen license.
D - 1.4  Network License Setup

To use a network license, you or your system administrator must first install the Reprise License Manager (RLM) and the license key for your product on a network server. (See the installation instructions included with the RLM download.) Once this has been accomplished, follow these steps:

1. Make sure the “Network” license type is selected in the Licensing dialog.
2. Enter the server name (you may use a hostname or IP address) and port number of the license server in the fields provided.
3. Click OK to save the license information.

Tecplot Chorus will now use a license obtained from the license server. If the product is unable to obtain a license key, an error message will appear, and you should verify that you have specified the correct network license information.

D - 2  License Roaming

Network license users who need to use Tecplot Chorus while not connected to the same network as their license server (for example, while traveling) can use license roaming. License roaming allows you to use the product without access to the license server for a limited period of time. The roaming license is considered “in use” by the server continuously until it expires or is returned.

To manage license roaming, choose License Roaming from the Help menu. The License Roaming dialog appears.
License Management

D - 2.1 Starting Roaming

To start roaming, choose the expiration date for the roaming license using the pop-out calendar that appears when you click the roaming expiration date. Your license will expire at the end of that day, at midnight.

To account for time zones, we suggest roaming for a day longer than you think you need when you will be traveling.

Click **Begin Roam** to obtain the roaming license and begin roaming.

The license server administrator and the license key may restrict the maximum amount of time users may roam and/or the total number of licenses that may roam at a given time. Additionally, only one instance of Tecplot Chorus may be run while roaming.

While roaming, the license status is noted as Roaming in the Licensing dialog, and the expiration date of the roaming session is also shown. You may not change license information while roaming.

When you are getting close to your roaming license’s expiration date, a notification appears in the Welcome Screen at startup.

Do not upgrade Tecplot Chorus while roaming. If you do, your license may no longer work correctly. Set the **RLM_ROAM** environment variable to -100 before launching to rectify this situation (see **RLM_ROAM**).

D - 2.2 Ending Roaming

Your roaming license expires automatically at the end of the day (that is, midnight) on the day you selected when you began roaming. After this date, your computer must be able to connect to the network license server to run Tecplot Chorus.

You may also end roaming early and make your license available for other users. To do this, you must first connect your computer to a network that allows you to reach the license server. Then choose **License Roaming** from the Help menu and click the **End Roam** button in the License Roaming dialog.

D - 2.3 RLM_ROAM

You can initiate roaming from the command line by setting the **RLM_ROAM** environment variable to the number of days you wish to roam, then starting Tecplot Chorus from that command line session. The roaming session expires at the end of the day after the number of days specified (for example, if it is noon Tuesday, and you set **RLM_ROAM** to 2, the roaming license expires at the end of the day Thursday). **RLM_ROAM**
License Roaming

may also be set to the special value \texttt{today} to have the roaming license expire at the end of the current day (the value \texttt{0} means that no changes to roaming will be made).

If \texttt{RLM\_ROAM} is set permanently (for example, using the System Properties in Windows), the license roaming will be refreshed each time you run Tecplot Chorus while connected to the network. If \texttt{RLM\_ROAM} is 1, for example, each time you start Tecplot Chorus, the roaming license is refreshed to expire at midnight the following day. This allows you to easily take your computer home with you any night and continue using Tecplot Chorus while disconnected from the license server, without needing to explicitly roam each day.

You may end a roaming session early by setting \texttt{RLM\_ROAM} to \texttt{-1} before launching Tecplot Chorus.

\textbf{Tip:} If you are having trouble ending your roaming early (a common cause is upgrading Tecplot Chorus while roaming), try setting \texttt{RLM\_ROAM} to \texttt{-100} before launching Tecplot Chorus. The roaming license will be forcibly removed from your workstation, and Tecplot Chorus will begin requesting a regular license from a license server at each startup. At this point you can obtain a fresh roaming license, if desired. The reservation for your previous roaming license will, however, continue to be held on the license server that issued it until it expires.
License Management
Glossary

A

absolute path: A path that specifies all the directories containing a file starting from the root of the file system (Linux), the root of a particular drive such as C: (Windows), or the root of the network (also Windows). A path is absolute when it begins with a drive letter or a slash.

add-on: A plug-in software module for Tecplot 360 EX. The Chorus add-on allows certain Tecplot Chorus features to be integrated tightly with Tecplot 360 EX.

append: Generally, to add more data to the end of a file. In Tecplot Chorus, refers to the ability to add new cases and/or variables to a project.

auxiliary file: An image or data file associated with a specific case in a Tecplot Chorus project.

B

background job: See job.

C

calculated variable: A variable in a Tecplot Chorus project calculated from other variables in the project using a formula you provide.

case: A simulation or experiment carried out for a given combination of input variables or parameters. In Tecplot Chorus, a case is represented by a record that stores the input variables, the output or result variables, informational fields, and links to auxiliary files. Compare with run.

Case ID: An internal Tecplot Chorus variable that uniquely identifies each case record. Case ID is an integer that starts at 1 for the first imported case and increases by 1 for each additional case. The variable name “Case ID” is reserved for use by Tecplot Chorus.

Case Status: An internal Tecplot Chorus variable that indicates whether cases are active or inactive, allowing inactive cases to be filtered from the view. It can be set by selecting cases in any Tecplot Chorus project.
Glossary

view and clicking the right mouse button. This variable is added to the project the first time it is used, so it might not exist in a given project. If it does not exist, all cases are active. The variable name “Case Status” is reserved for use by Tecplot Chorus.

**CFD:** See *computational fluid dynamics.*

**checkbox filter:** A filter that allows values of a given variable to be selected for display by clicking a checkbox. Best suited for variables having a small number of discrete values.

**Chorus add-on:** A plug-in module that allows the integration of certain Tecplot Chorus features into Tecplot 360 EX. These features can be found in the Chorus sidebar in Tecplot 360 EX.

**computational fluid dynamics:** an approach to analyzing fluid flow problems (such as the location and magnitude of the vortices created by an airfoil as wind passes over it) using numerical methods and algorithms, rather than by examining a model in a wind tunnel.

**crawler:** Generally, a program that scans a file system, the Web, or some other external data source and imports information about the data it finds into a database. See *file crawler* for its use in Tecplot Chorus.

**CSV file:** Short for “comma-separated-value file.” A type of delimited text file in which a comma is used as the delimiter. Frequently used for data interchange.

**data view:** See *view.*

**deep dive:** From Tecplot Chorus, viewing the data for a given case or cases in Tecplot 360 EX. The metaphor is that the aggregate view of all your cases in Tecplot Chorus is the surface of a vast ocean of data. To investigate cases of interest in more detail, you dive deeper, inspecting the full case data (not just the metadata) in Tecplot 360 EX.

**delimited text file:** A plain-text file that typically contains data to be imported to a project, with a delimiter such as a tab or a comma between each field in a given line. When a comma is used, the file is often called a CSV file. When importing data into Tecplot Chorus from such a file, each line in the file represents a single case, and the individual values in that line are the variables associated with the case.

**delimiter:** A character that separates the fields in a data record. For example, in a directory path like C:\Users\Jerry, the backslash is used as a delimiter for the directories in the path. In a CSV file, the delimiter is a comma, and is used to separate the fields on each line of the file.

**dependent variable:** The output or result of a computation (and sometimes these terms are used instead). For example, an aerodynamic simulation of an airfoil design will have outputs such as lift and drag, which will be described in Tecplot Chorus as being dependent variables.

**deposit:** In Tecplot Chorus, the action of storing generated image or data files into a project. These files are generated by a background process but are not stored in the project until you specifically instruct Tecplot Chorus to deposit them.

**design space:** An abstract space (possibly highly dimensional) consisting of all the possible values of the input variables in an experiment. A CFD experiment is often an attempt to search the design space for an optimal design for an aircraft or a component such as an airfoil.

**diff:** In general, a visual representation of the differences between two files (“a diff”), or, as a verb, the action of producing such a representation (“diff these images”). Tecplot Chorus can produce diffs of multiple images associated with cases or, in a deep dive, you can have Tecplot 360 EX produce diffs of actual data files.

**display name:** The name by which a variable in a given project is known and displayed in Tecplot Chorus. This may be different from the way the variable is identified in the original files. Variable names may be
mapped to display names when the variable is added to a Tecplot Chorus project. For example, a variable may be called “M” in the original data, but “Mach Number” in Tecplot Chorus.

**docking:** The Filter and Options panels in Tecplot Chorus may be dragged to the edges of the Tecplot Chorus window or to each other and will “stick” to these elements, and are then said to be “docked” to the window. When you move the edge of the window, for example to resize it, the panels move with it. These two panels can also be docked together in a single space; only one will be visible at a time in this case, with the visible panel chosen by a tab.

**E**

**employed:** When a variable is used in some fashion in a plot (for example, as an axis, or to determine the size or color of a symbol on a scatter plot), it is said to be employed by the plot.

**evaluation point:** the collection of query values to be used for surrogate model input variables that are not being used in a plot. Only one value is used per variable.

**experiment:** A group of related CFD cases (or other calculations or real-world tests) intended to investigate an engineering issue or to optimize a design, e.g., of an airfoil. The required input variables, their ranges, and the specific values of each variable to be tested (i.e., the design space), along with the outputs to be generated, form the basis of an experiment. An experiment usually, but not always, corresponds to a Tecplot Chorus project.

**export:** Generally, to save data to a format that makes interchange easier. In Tecplot Chorus, you may export a project to a CSV file for sharing with others or for importing to a spreadsheet for further analysis or for publication.

**expression:** A mathematical formula; in computer software, usually one entered using a special notation or syntax that is easier to type on a computer keyboard than traditional mathematical notation. In Tecplot Chorus, you can create calculated variables by entering an expression.

**F**

**file crawler:** A Tecplot Chorus feature that scans the directories (folders) on a disk or network share to extract variable names and values for the cases in a project, based on the names of the directories in which the case’s data files are found.

**filter:** Generally, to exclude unwanted data items from consideration or display based on some criteria, or (as a noun) a mechanism for doing this. In Tecplot Chorus, you may filter based on the values of any variable in the project using checkboxes or listboxes of discrete values, ranges, or single values.

**foreign data:** Generally, any data that is not in a program’s native format. In Tecplot 360 EX, native formats include .dat, .plt, .szplt, .lay, and .lpk files. Foreign data formats include CGNS, Fluent, PLOT3D, and other popular solver output file formats. Tecplot 360 EX can read these formats, but this is an import operation; it cannot write these formats.

**function:** A mathematical rule that associates given inputs to an output. In Tecplot Chorus, a function (also called an expression) may be used to calculate new variables from existing variables in a project. Also, the functions implied by a project’s metadata may be approximated using the surrogate model feature.

**highly dimensional:** describes a data set with many input variables, each of which describes a dimension of the design space. It is difficult for most people, even mathematicians or engineers, to visualize and reason about abstract spaces having more than three or four dimensions because human beings have such little
everyday experience with higher-dimensional data. Many CFD projects have more than a dozen parameters or dimensions.

**histogram**: a plot showing the relative frequency of values in a variable's range, often with values grouped into bins. For example, the range filter in Tecplot Chorus includes a histogram showing where the most frequently-appearing values can be found in a variable's range.

**import**: Generally, to read data that is not in a program's native format. Tecplot Chorus can import project metadata from a delimited text file, from a directory structure using its file crawler, or from the auxiliary data stored in solution data. Tecplot 360 EX can import grid and solution data in a variety of formats.

**independent variable**: A variable that is being manipulated or changed to investigate the effects on a function to which it is an input. For example, in a CFD simulation of flow around an airfoil, Mach Number, alpha, and beta are common independent variables. Also called an input or parameter.

**input**: A synonym for independent variable, usually paired with output.

**job**: In Tecplot Chorus, a background process that creates images or Tecplot 360 EX layout packages, or extracts variables, from the data files associated with selected cases in a project. When such a process is in operation, the Manage Jobs button in Tecplot Chorus's status line becomes available to allow you to delete jobs or deposit their results into the project.

**Kriging**: A least-squares estimation method, originally from geology, that allows the value of a variable at an unobserved (i.e., unsimulated) location in design space to be approximated from the values of the variable at nearby locations using a function called a variogram. A more sophisticated technique than a response surface, Kriging guarantees that the generated shape will pass through all observed points. Tecplot Chorus can use Kriging to generate a surrogate model.

**layout (.lay file)**: In Tecplot 360 EX, a file that stores the appearance of the current plot, including which zones and variables are displayed, the visual style of each, the zoom and rotation, and so on, along with references to the files that contain the data sets. The actual data is not stored in the file.

**layout package (.lpk file)**: In Tecplot 360 EX, a layout file that also includes the data necessary to reproduce the plot as specified in the layout file. Data for zones or variables that are not visible is not included, and the data is stored in Tecplot's binary format, so layout packages can be much smaller than the original data file. They are a good format for sharing with others, since they can be viewed with the free Tecplot Viewer.

**legend**: In Tecplot Chorus, a guide to the colors or line patterns used in a plot.

**line plot**: In Tecplot Chorus, a two-dimensional plot that places cases on a grid based on the value of two variables, connecting adjacent cases with lines. The lines can be grouped based on the value of a third variable, in which case a separate line is drawn, in a different color, for each discrete value of this variable.
link: In Tecplot Chorus, a text variable that specifies the path of an auxiliary file associated with a case. The auxiliary files are not stored in the project, so their path (relative to the project root) serves to link the case record in the Tecplot Chorus project to the image or data file stored elsewhere.

listbox filter: A filter that allows values of a given variable to be selected for display by selecting them in a scrolling list. Best suited for variables having a large number of discrete values.

M

macro: A macro (.mcr file) is a way of automating Tecplot 360 EX. Virtually anything you can do in Tecplot 360 EX can be recorded in a macro and later played back with entirely different data. Tecplot Chorus can automatically run a macro when opening data files in Tecplot 360 EX or when generating images or layout packages, allowing you to customize the process as needed.

master: In an image or data comparison (diff), the image or data file to which other images or data files are compared. Differences from the master are shown for each file being compared with it.

matrix: A view of a Tecplot Chorus project that shows image thumbnails for cases that have them. Variables can be chosen to sort the cases into rows, columns, and optionally pages.

metadata: In general, means “data about data.” In Tecplot Chorus, refers to the independent variables (inputs) used in each case, the derived dependent variables (outputs) calculated by the solver—such as lift, drag, and pressure—aggregated over the entire solution, links to related files, and, often, housekeeping information such as the name of the engineer who ran the simulation, the date it was run, a case serial number, and so on. Does not refer to the full solution data (i.e., the outputs for each cell in a grid). Tecplot Chorus is a tool for organizing cases and visualizing your design space based on metadata; Tecplot 360 EX is a tool for visualizing individual cases’ solution data.

model: See surrogate model.

N

NaN: Means “Not a Number.” The text “NaN” may be included in numeric data to indicate that a value is missing or invalid for a particular case. Tecplot Chorus refers to “NaN” as a null value.

nature: see variable nature.

null value: A missing or invalid value of a variable, which can be designated as NaN (“Not a Number”) in a delimited text file. You can use filters to show or hide cases having null values.

O

operator: A symbol representing an arithmetic operation: In Tecplot Chorus, + for addition, - for subtraction, * for multiplication, / for division, and ^ for exponentiation. See expression and calculated variable.

output: A synonym for dependent variable, usually paired with input.

P

page: In Tecplot 360 EX, a drawing area that may contain multiple frames, each showing a view of a dataset. Tecplot 360 EX supports multiple pages; a new one is opened each time you view data from Tecplot Chorus, rather than opening a new instance of Tecplot 360 EX. Pages can be managed using the Chorus sidebar.
Glossary

path: A textual representation of the directories containing a file, used to specify the file's location on the computer. An absolute path starts at the root of the file system (Linux), at the root of a particular local drive such as C: (Windows), or at the root of the network (also Windows). A relative path assumes starting at some other known directory (such as the user’s home directory or a project directory) and specifies the file's location in the hierarchy “below” this directory.

parameter: A synonym for independent variable, often paired with result.

parametric CFD: An application of CFD to design tasks such as optimization that require an exploration of a design space. Simulations are run with various combinations of parameters, or input variables, to find cases that meet or optimize the established design criteria.

pattern: A way to specify a filename that allows one to select more than one file without specifying the names of each individually. Wildcards may be used to match partial names. For example, when tagging files with Tecplot Chorus, case* matches any file whose name begins with “case,” while *.png matches any PNG file.

PNG or Portable Network Graphics: A free file format for storing images, well-suited for reproducing crisp line art and text. Tecplot Chorus can export any image or plot in PNG format.

project: In Tecplot Chorus, projects are containers for related cases. Each case is represented by a record that stores the case’s variables. A separate location on your computer’s disk or a network share is used to store auxiliary files associated with each case. Tecplot Chorus plots and other views are derived from the cases in the project.

project root: See root path.

properties: Each plot and view of your Tecplot Chorus project has settings, referred to as properties, that determine its behavior and appearance. Each window (even different windows displaying the same kind of plot) has its own properties. The properties appear in the Properties panel, which initially appears at the left of the workspace but can be docked to any edge of the window you find convenient, or dragged outside the Tecplot Chorus workspace—even onto a second display.

quadratic response surface: See response surface.

query: After a surrogate model has been trained, Tecplot Chorus can ask it for predictions of output variables based on specific input values (query values), which may or may not represent actual cases in the project. This is called a query; the verb form is making a query or querying.

query values: The input variable values used in a query to a surrogate model.

range filter: A filter that allows you to specify the first and last value of a variable that you wish to be included in your Tecplot Chorus views. Useful for variables with continuous values. A histogram is also displayed with this filter to give you an idea of the value distribution.

range and sampling: Specifies the query values to be used for input variables to a surrogate model when those values are being used on the plot. The low and high values are specified (the range) along with the number of values to be chosen between them (the sampling).

relative path: A path that specifies the directories containing a file relative to some directory, such as a user’s home directory or a project directory. Relative paths generally do not start with a drive letter or a slash.
response surface: an approximation similar to a curve fit, except in n dimensions. Tecplot Chorus can use a quadratic (second-order) response surface in a surrogate model. This is appropriate for modeling many physical phenomena because they are commonly at most quadratic.

result: A synonym for dependent variable or input, often paired with parameter.

root path: A directory (folder) on your computer’s hard disk, or on a network file share, that contains the auxiliary files associated with a Tecplot Chorus project. These can include files created by your solver or generated in post-processing, as well as files created by Tecplot Chorus.

rotate: A tool that allows you to rotate 3D plots and literally see your project from another angle.

round trip: The process of creating a style template in Tecplot 360 EX for a single case, then using Tecplot Chorus to apply that template to the data files of multiple cases to generate an image or a layout package, and finally importing the generated images or data files into Tecplot Chorus.

run: A noun referring to a simulation being run using a particular combination of parameters or inputs. Some CFD engineers use this term instead of, or as a synonym for, case. In some circles, however, the term case is preferred, and run may have a slightly different meaning; for example, if you simulate the same case multiple times, you would have multiple runs, but still only a single case.

scatter plot: A Tecplot Chorus plot that places cases on a grid based on the values of two parameters. This plot is useful for revealing correlations between variables as well as for finding unexpected clustering of cases. Tecplot Chorus offers both 2D and 3D scatter plots.

selection: Data (in Tecplot Chorus, cases) chosen for some future operation. Cases can be selected in any view of a Tecplot Chorus project, including plots. Once selected, the images or data files associated with the cases can be viewed and compared, new images or data files can be generated, and so on.

session: In Tecplot Chorus, a file that records the current project and all open views and their properties, including the locations and sizes of all windows. Opening the session file returns you to the exact place you were when you saved it. This capability can be used to record typical starting points for working with a project or to save your place from day to day.

sidebar: The container for the Filters and Properties panels that initially appears at the left of the Tecplot Chorus windows. These panels can be docked to other edges of the window, however, or moved out of the Tecplot Chorus workspace entirely, even to a second display.

simulation analytics: An approach to managing, interpreting, and visualizing the results of large CFD experiments being pioneered by Tecplot Chorus.

single value filter: A filter that passes only cases where the selected variable matches a single value, useful for “slicing” through discrete values of a variable.

solver: A software package that calculates a CFD simulation and produces a solution file that can be visualized by a tool like Tecplot 360 EX, as well as generating aggregate results (such as the overall lift, drag, and pressure) that can be used to help organize the results in a tool like Tecplot Chorus.

sparse: An adjective that refers to a CFD experiment where not very many cases have been simulated relative to the size of the design space. Due to the time required to run simulations, most CFD experiments are sparse to one degree or another—highly-dimensional experiments especially so, due to the geometric expansion in the number of cases as dimensions (variables) are added.

status line: The line at the bottom of the Tecplot Chorus window that displays the name of the current project and information about any background jobs that are currently in progress.
Glossary

**style sheet**: A file saved from Tecplot 360 EX that records the visual appearance of the current plot. This can then be applied to similar data sets to produce a series of plots that can be easily compared to each other by eye. See **style template**.

**style template**: A Tecplot 360 EX style sheet that is used in Tecplot Chorus to automatically generate images or layout packages for selected cases.

**surrogate model**: A mathematically-derived proxy of an experiment generated by correlating the inputs and outputs of cases that have already been simulated, which can be used to predict the values of cases that have not yet been simulated. If you think of it as an n-dimensional curve fit, you won’t be far off. A surrogate model can be generated much more quickly than running even a single additional simulation, making it a useful analysis tool despite its approximate nature. Tecplot Chorus supports surrogate models based on a response surface or Kriging.

**synchronize**: In Tecplot 360 EX, the Chorus sidebar can be used to synchronize styles (the plot appearance) from the selected case to other cases so that they are easily compared visually.

**syntax**: Generally, the grammar of a statement. In **expressions** such as the ones used for calculated variables in Tecplot Chorus, refers to the correct placement of symbols representing mathematical operations. For example, every addition operation must have two terms, one on either side of the + sign; every opening parenthesis must have a corresponding closing parentheses. If syntax rules are not obeyed, Tecplot Chorus cannot evaluate the expression.

**symbol plot**: A Tecplot Chorus line plot in which no lines are used to connect the cases. Instead, a symbol such as a square is plotted for each case. May be combined with a line plot so that it is clear where on the line the cases are, which may be difficult to determine for some kinds of data.

**table view**: In Tecplot Chorus, a spreadsheet-like view in which each case is represented by a row, and each variable by a column. Shows the actual variable values for each case.

**tag**: A short identifier (such as “Wireframe Image” or “Contour Data”) that is used to identify an image or data file in Tecplot Chorus. Each tag has an associated **pattern** that is used to identify which files are selected by the tag, which may contain **wildcards** in case the files have not been named consistently. Tags for some kinds of data files may identify multiple files at once.

**tag group**: A way to manage related tags in the image viewer and the matrix view, allowing them to easily be turned on or off together. Also determines the order of tags when viewing by tag in either window.

**template**: see **style template**.

**tile**: As a verb, to arrange windows so that they are all the same size and not overlapping, so you can easily find the one you want. Tecplot Chorus can tile windows with a single click of the mouse.

**toolbar**: The row of buttons at the top of the main Tecplot Chorus window that allows you to perform a variety of functions with a single click.

**training**: The process of generating a **surrogate model** by analyzing the implicit correlations between input variables and output variables in a Tecplot Chorus project, allowing the model to make useful predictions for cases that have not been simulated.

**translate**: To move a Tecplot Chorus plot within its window. In some plots this changes the axis range, which has much the same effect. So named because in either case, you are essentially changing its coordinates.
variable: One of several named values associated with a particular case in a CFD experiment. Each case will have the same variables, but the values of each variable may differ for each case. The purpose of each variable is its variable nature.

variable nature: In Tecplot Chorus, the purpose of a variable: independent (input or parameter), dependent (output or result), or other (informational fields, links to auxiliary files, and so on).

view: In Tecplot Chorus, any window that displays the cases in your project is a view, or a data view. This includes the matrix, the table, and all plots.

Welcome Screen: In Tecplot Chorus, the Recent Projects screen that lets you easily open projects you have been working with recently and create a new project with the click of a button. Choose View > Welcome Screen to see it.

wildcard: A special character such as * or ? that can be used in a pattern to match any letter or number in a file name. For example, case* would match any file name starting with “case,” while *.png would mean any file name ending with “.png”.

workspace: The main part of the Tecplot Chorus application window where plot and view windows appear. Windows may be dragged out of the workspace, even to a second display.

XML: The eXtensible Markup Language, a standardized, easily-extended text format for storing and exchanging data. Tecplot Chorus uses XML for loader description files, custom action registration and instruction files, and session files.

zoom: In Tecplot Chorus, the ability to magnify (zoom in to) or shrink (zoom out of) plots. In some plots, the axis ranges are changed instead; the intent is to display more or less data rather than literally making the plot larger or smaller.
Index

Numerics
2D scatter plot 8, 13, 41
3D scatter plot 8, 13, 41
properties 44
surrogate model 69, 72

A
about screen 12
actions 65, 85-88
auxiliary files 17, 22, 26, 53, 56
root folder 21
axes 47, 48
in 2D scatter plot 42
in 3D scatter plot 44
range 13

B
background jobs 15, 62, 63, 64

C
calculated variables 29-30
Case ID 23, 27
Case Status 23, 27, 36, 45, 48
CGNS 80
checkbox filter 36
Chorus sidebar 57, 58, 59-60
coefficient of determination 71, 73
coma-separated value
see CSV file
comparing data 8
comparing images 8
display name 23, 27
docking panels 14
toolbar 12

D
data comparison 8
data files
creating 63
loading 56-58, 61, 79-83
removing links 31
tagging 10
data loader 79
deep dive 9, 37, 56, 61

Delete Variable 50
deleting cases 50
delimited text file 19
selecting 21
delimited text reader 19, 28
differences
in data 59, 60
in images 55
display name 23, 27
docking panels 14
toolbar 12

E
Edit menu 12
ingeering data 50
export
derived data 32
plot 42, 44, 46, 55
project to CSV file 32
expressions 30
external files
tagging 10
extracting variables 63
extraction jobs 15

F
File Crawler 19, 23-28
extracting variables 24
root folder 24
source name 25
File menu 12
filter violations 42, 43
filters 9, 35-37
checkbox filter 36
constraint visualization 35
enabling/disabling 37
listbox filter 36
panel 34, 35
range filter 35
resetting 37
single value filter 35
Filters panel 11, 34, 35
functions 30

gear icon 35, 37
getting started 16
goodness of fit 71, 73

H
help
from dialog 16
Help menu 12, 16
hiding filters 37

image comparison 8
INDEX

images
  copying to clipboard 55
  creating 60–62
differences 55
properties 54
lagging 10
thumbnails 37
viewing 53
zooming 54
invalid data 36

J
  jobs 15, 62, 63, 64
JPEG 53

K
  Krigeing 69

L
  labels 38
  layout package 63
legend
    in line and symbol plots 47
license 12
line plot 8, 13, 33, 46–48
properties 47
selecting cases 48
surrogate model 69, 71
linking files 22, 26
removing link 31
listbox filter 36
loader 79
loader description 79, 80

M
  macro 57, 61, 80, 82
  magnify
    see zoom
managing filters 37
managing jobs 15, 62, 63, 64
master 60
matrix view 8, 13, 33, 37–39
properties 38
selecting cases 39
menu bar 11, 12
metadata 8, 17
missing data 36
moving plots 13

N
  NaN 9, 36
  nature of variable 23, 28, 31
  Not a Number
    see NaN
null value 36

O
  opening a session 16
  opening projects 18
operators 30
organizing a study 9

P
  panels 14
    Filters 34, 35
    Properties 34
  Paraview 65, 85, 86
  pass null 36
  pattern 25
plot
    exporting 55
plots 8
  2D scatter 8
  2D scatter plot 13, 41
  3D scatter 8
  3D scatter plot 41
  exporting 42, 44, 46
  line plot 8, 13, 33, 46–48
  moving 13, 45
  resetting 45
  rotating 13, 45
  scatter plot 41–45
  symbol plot 8, 13, 33, 46–48
  PNG file 42, 46, 53, 55
Project
  removing links 31
  Project menu 12
  projects 8, 12, 17–32
  appending to 28, 63
  creating 18–28
  deleting 32
  deleting cases 30
  deleting variables 50
  delimited text reader 19, 19–23
  editing data 50
  exporting 32
  File Crawler 19, 23–28
  importing CSV 19
  opening 18
  root path 32
  saving 17
properties
  2D scatter plot 42
  3D scatter plot 44
  image viewer 54
  line plot 47
  panel in sidebar 11, 34
  scatter plot 42–44
  symbol plot 47
  table view 51
proxy
    see surrogate model
Python 86, 87
R
  range filter 35
READDATASET 80
Release Notes 16
removing linked files 31
renaming variables 23, 27
reserved variable names 23, 27
reset view 12
resetting filters 37
resetting the view 45
response surface 70
restoring a session 16