Additional Resources

In addition to these Release Notes and HTML Help, Tecplot Focus includes access to the following manuals.

- **User’s Manual**  This manual provides a complete description of working with Tecplot Focus features.
- **Scripting Guide**  This guide provides Macro and Python command syntax and information on working with Macro and Python files and commands.
- **Quick Reference Guide**  This guide provides syntax for zone header files, macro variables, keyboard shortcuts, and more.
- **Data Format Guide**  This guide provides information on outputting simulator data to Tecplot Focus file format.
- **Installation Guide**  These instructions give a detailed description of how to install Tecplot Focus on your machine.

**My Tecplot**

My Tecplot is Tecplot’s one-stop portal that allows you to download software, manage your license keys, and more. Visit it at [https://my.tecplot.com/](https://my.tecplot.com/).
Welcome to Tecplot Focus 2020 R1

Tecplot Focus 2020 R1 is now based on the Qt 5 GUI toolkit, which provides better support for MacOS and high-dpi (4K) displays. In addition to the major items below there are over 25 minor enhancements and bug fixes.

If you don’t see the improvement or bug fix you wanted, let us know what’s missing by contacting us at support@tecplot.com.

What’s New In Tecplot Focus 2020 R1

• Evenly Spaced Vectors - Get a better understanding of flow by using the new evenly spaced vector capability. Access this feature via Plot>Vector Details… or via the new icon on the Plot Sidebar. Even vector spacing works in 2D and 3D plots and works on all objects: Zones, Slices and Iso-surfaces.

• Streamtraces on No-Slip Surfaces - Tecplot Focus will now auto-detect a no-slip surface and use the velocities from the neighboring volume to draw the surface restricted streamtrace. This feature also works with structured data in which the surface is represented by, for example, the $K=1$ plane.

• Faster Batch Mode Image Export - Linux in batch mode can now take advantage of hardware-accelerated graphics, yielding up to 4.6x faster image export. Even software-rendering speed has improved with up to a 2.3x speed improvement.

Platform Support Changes

Tecplot Focus 2020 R1 release is supported on the following platforms:

• Ubuntu 16.04 LTS, 18.04 LTS, 20.04 LTS
• SUSE Linux Enterprise Desktop (SLED) 15
• Windows 10
• RedHat 6.10, 7.5+, 8.0+
• CentOS 6.10, 7.5+
• Mac 10.13, 10.14, 10.15

Previously supported platforms that are not supported by Tecplot Focus 2020 R1:

• SUSE Linux Enterprise Desktop (SLED) 12 (end of life December 2019)
• SUSE Linux Enterprise Desktop (SLED) 11.4 (end of life March 31, 2016)
• Ubuntu 14.04 LTS (end of life April 2019)
• Windows 7 (end of extended support, January 2020)
• Mac 10.12

New Graphics Card Requirements

The Qt 5 toolkit requires graphics cards that support Frame Buffer Objects (FBOs). Most modern graphics cards support this. However older machines and some remote display configurations may not provide support for FBOs. If you encounter rendering issues see Rendering and Export Troubleshooting in the User’s Manual.
**Bug Fixes and Minor Enhancements**

- Fixed drawing interrupted issue when double clicking on text.
- Fixed missing scroll bar for combo boxes on some Linux and Mac platforms.
- Mesa (software-rendering) libraries are now distributed on Windows, to support machine configurations that have insufficient hardware graphics support.
- Setting contour levels now correctly uses 0 instead 1e-17.
- Extract menu updated for consistency.
- Updated TecIO to build with g++ 9.2.
- Fixed a performance regression of the Plot3D loader for data with lots of zones/stands.
- Reverse continuous colormaps now render correctly.
- Fixed crash when launching Text Details dialog for 3D text.
- Fixed crash when switching geometry draw order with 3D polyline.
- Resetting contour levels with only slices drawn no longer incorrectly reports "No Visible Style" error.
- Fixed crash when deprecated 2013 colormap macro commands are used.
- Disallow negative Text Box Margin values, preventing a crash.
- Switching vector plot from 2D to 3D now calculates the default vector length rather than setting the length to 0.
- Fixed crash when exporting postscript with polyhedron data and vectors plotted at Surface Cell Centers.
- Added missing macro commands for Max Value In Column Add-on.
- Fixed bug where Vector Details dialog would only update 2D or 3D frames but not both.
- Allow resetting of contour levels when only slices are displayed.
- Fixed loading of .lay files with Mac end of line (\r).

**Known Issues**

- Most recently used (MRU) files will not persist from earlier releases of Tecplot Focus, all MRU files will begin fresh and be independent from Tecplot Focus 2019 R1 and earlier. Window size & position is also now independent from Tecplot Focus 2019 R1 and earlier.
- Due to changes in graphics card requirements, Linux batch mode image export may no longer export images with default command line arguments. See Rendering and Export Troubleshooting in the User's Manual.

**Bug Fixes and Minor Enhancements in 2020.1.1**

- Fixed MP4 and WMV animation exports for older Linux platforms such as CentOS 6.10 (Linux kernel prior to 3.2).
Welcome to Tecplot Focus 2020 R1

What’s New In Tecplot Focus 2019 R1

Highlights of Tecplot Focus 2019 R1

- TecIO-MPI write speed improved by ~15x via output file caching and reducing data exchanges.
- TecIO now allows writing of polyhedral zones with up to 2 billion cells. The previous functional limit was approximately 175 million cells (depending on the number of faces per element). See TECPOLYZNE142 in the Data Format Guide.
- Extracting slices over time more tightly integrated. The Data > Extract > Extract Slices Over Time... menu option has been removed. Please use Data > Extract > Extract Slices... or the Extract Slices... button on the Slice Details dialog.
- Saving a layout after extracting primary slices no longer forces saving the data.
- Reprise License Manager (RLM) updated to 12.4.

Bug Fixes and Enhancements

- Layouts now load when there are apostrophes in the .plt file’s variable names.
- New macro preprocessor directives allow macros to skip over newer instructions based on Tecplot revision for future backward compatibility.
- Fixed crash when saving a multi-dataset layout with the IJK Blanking dialog open.
- Contour levels listed in the Contour Details dialog now correctly displays lists for zero-contour-level-groups.
- Added --help command line option.

Tecplot Focus vs. Tecplot 360 EX

If you need any of the following features, we suggest you consider Tecplot 360 EX.

- The ability to load data files containing more than 5 million data points
- CFD analysis tools, found on the Tecplot 360 EX Analyze menu, including integration capabilities
- Access to Tecplot’s new high-performance subzone data file format, .szplt
- The ability to load data in CFD formats such as Fluent, FLOW-3D, EnSight, ANSYS, OpenFOAM, and more through native data loaders
- The ability to load data files containing face-based (polygonal and polyhedral) zones
- Access to the following features while you maintain a valid TecPLUS subscription:
  - Tecplot Chorus, our simulation analytics tool for engineers who work with large numbers of cases
  - PyTecplot, an interface to the Tecplot engine via the Python programming language
  - Tecplot SZL Server, which gives you simple, secure access to your Linux-hosted remote data

TecPLUS is the replacement for Software Maintenance Service (SMS).

Usage Data Collection

To help us better understand how our customers use our products and improve them further, Tecplot Focus includes an analytics feature that reports user activity over the Internet using the Google Analytics™ platform. This feature tells us which dialogs you use and which controls you manipulate in them. However, to protect your privacy and trade secrets, we do not see names associated with your data (such as variable, zone, or file names) or the actual values of fields in dialogs, nor do we receive any information about you or your organization’s identity.

If you do not wish to participate in this program, turn off “Collect Anonymous Usage Data” in the Help menu.
We receive basic information about your operating system, product version, and license at each launch of Tecplot Focus, even if you have opted out of the usage data program. This information is not tied to any usage data collected.

No usage data of any kind is collected if you do not have access to the Internet or if the Google Analytics service is blocked by a firewall.

### Crash Reporting

Please help us make Tecplot Focus better by submitting a crash report to us in the event that the application terminates unexpectedly.

On Windows, Tecplot Focus creates a crash dump file. You will receive a message indicating that a crash dump file has been created. Click Yes in this dialog to open the folder where the file is created. You can then e-mail the most recent .dmp file in this folder, along with a description of what you were trying to do, to support@tecplot.com.

On other platforms, no crash dump file is created. However, we urge you to send us a report anyway with as much detail as you can remember.

If you have a moment and a desire to be extra helpful, please re-open Tecplot Focus and choose Enable Diagnostic Logging in the Help menu. Then redo the steps you took to cause the crash. If you are able to reproduce the crash, send the resulting .mcr file to us (along with the .dmp file if you use Windows). On non-Windows platforms, you can find the .mcr file in /usr/tmp/tecplot_$USER/tpa_diagnostics.

Crash dumps and diagnostic macros are stored in a temporary folder and will be eventually be deleted automatically. There is no need to delete them manually.

### Graphics Drivers

For best results, please make sure that you are using the latest graphics drivers compatible with your hardware and operating system. These can be obtained from your graphics adapter vendor’s Web site. Old versions may have issues with Tecplot Focus, especially with larger data sets.

- ATI: https://www.amd.com/en/support

### Platform-Specific Notes

The following table outlines the support for various platform-specific features in Tecplot Focus 2020 R1.

<table>
<thead>
<tr>
<th>Excel Loader</th>
<th>Linux</th>
<th>Mac</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>

Refer to the remainder of this section for issues specific to your operating system.

### Windows

Your account must have administrator rights on your computer to install Tecplot Focus, or else right-click the installer and choose “Run as Administrator.”

### Linux

- Temporary Directory
Tecplot Focus EX relies on being able to create temporary files in the system temporary directory. On Linux, this directory is typically /usr/tmp or /var/tmp. If your user account does not have permission to write into the system temporary directory, you can use a different directory either by setting the TMPDIR environment variable in your profile or by setting the TEMPFILEPATH in the tecplot.cfg file.

- **Menu Shortcuts**
  Menu shortcut keys may not work if the NUM LOCK is on. You may set the NUM LOCK to turn off automatically at boot in your computer’s BIOS.

- **SELinux**
  SELinux (provided with some Linux distributions) adds an extra layer of security. If you see this error message:
  ```
  ../bin/tecplot.shared: error while loading shared libraries: ../lib/libtec.so: cannot restore segment prot after reloc: Permission Denied
  ```
  Enter these two commands, replacing /path/to/tecFocus/lib with the actual path of your installed Tecplot Focus lib directory (your account needs sudo permission):
  ```
  sudo chcon -v -R -u system_u -r object_r -t lib_t /path/to/tecFocus/lib/
  sudo chcon -t texrel_shlib_t /path/to/tecFocus/lib/*/  
  ```
  You can then run Tecplot Focus EX without disabling SELinux.

- **Mac**
  - **Keyboard Shortcuts**
    Previous versions of Tecplot Focus used the Control key for most keyboard shortcuts, rather than the Mac standard Command key. Tecplot Focus changes these shortcuts to use the Command key under Mac. Similarly, when rotating a 3D plot, you now hold down the Command key while dragging with the right mouse button.
    Note that the Alt key may be called Option on some Mac keyboards.
  - **Right Mouse Button**
    If your Mac’s mouse has only a single button, hold the Control key while clicking to access right-click functionality.
  - **Middle Mouse Button**
    There is no functionality in Tecplot Focus that requires a middle mouse button; however, it does provide some shortcuts. Users of single-button mice cannot emulate the middle button, but users of mice with two buttons can hold down Control while right-clicking if their mouse does not support a true middle-button click.

Enjoy Tecplot Focus 2020 R1 and master the view!