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Additional Resources

In addition to these Release Notes, Tecplot RS includes the 
following manuals and HTML Help Library to help you 
explore all of Tecplot RS’s features. Your installation includes 
these manuals in the doc folder within your installation 
folder.

• Installation Guide This guide gives detailed 
instructions on how to install Tecplot RS on your 
machine.

• User’s Manual This manual provides a complete 
description of working with Tecplot RS features.

• Integrated Help Library You can access indexed, 
searchable Tecplot RS information by choosing 
“Tecplot RS Help” from the Help menu.

• For additional resources or help using Tecplot RS, visit 
our Web site at http://www.tecplot.com.

http://www.tecplot.com
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Welcome to Tecplot RS 2010 R2!
New Features in Tecplot RS 2010 R2
Welcome to Tecplot RS 2010 R2! This second release of 
Tecplot RS 2010 includes the following new features.

• A new Measure Distance tool shows you the 
straight-line distance between any two points on 
a grid.

• The new Quick Probe tool shows you the 
coordinates and contour variable value at any 
point on a grid, using the status line rather than 
the Probe dialog.

• A multi-well mode in History Match lets you see how 
well your simulation matches your actual data for 
selected wells at a given time step, in addition to the 
existing feature of comparing history data for a single 
well over time. An optional weighting factor allows the 
most important wells to be determined by a variable 
such as total production.

• Selection sets can now be exported to an XML file 
format for easy reuse and editing. They are still saved 
in projects and can still be loaded from there as well.

• Now you can drag multiple folders into the Tecplot RS 
workspace to load the data files they contain.

• A new HIST file data format being used by Chevron is 
now supported.

• REGION entities in CHEARS CSV files are now 
supported.

• The sidebar is less cluttered. Previously, many 
functions were available as buttons both in the toolbar 
and in the sidebar. These functions are now available 
only in the toolbar, giving you more room to work in 
the sidebar.
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New Features in Tecplot RS 2010
If you are upgrading from Tecplot RS 2009 or earlier, you will 
also enjoy features added in the first Tecplot RS 2010 release. 
There are so many, we’ve separated them into groups.

New User Interface and Architecture

• Modern Graphical User Interface looks and functions 
the same on Windows and Linux platforms.

• New, custom-designed icons for toolbar and other 
buttons make features easier to find and identify, and 
follow the MS Vista style standard.

• New dockable, moveable toolbar with buttons 
corresponding to major workflow steps provides quick 
access to more features with fewer clicks. With the 
new toolbar, you can:
Load Data 
Manage the data in 
your plot with fewer 
clicks using the New, Open, and Save Project buttons, 
and the Load XY Data, Load Grid Data, and Manage 
Data buttons.
Adjust View
Change the view 
on your plot 
easily with buttons to zoom, move, rotate, change light 
source, redraw and reset the view of your plot.
Edit Plot 
Make simple plot edits 
easily with the 
Selector tool, the Adjuster tool, and the Add Text, 
Change Plot Options, Manage Multiple Frames and 
Update Paper Layout buttons.
Investigate 
Plot 
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You can investigate your plot easily with the final 
grouping of toolbar buttons: probe for variable values, 
add streamtraces, blank cells, add a histogram or cross 
plot, integrate, and calculate new variables. The robot 
button lets you quickly play a macro.

• The sidebar is dockable, too, letting you move it to a 
convenient location, including out of the Tecplot RS 
window to maximize plot view in the workspace.

• Additional filtering choices facilitate easier searching 
of long lists.

• Automatic “smart” alpha-numeric sorting of variable 
lists simplifies variable selection.

• Re-organized, updated menus follow the typical 
reservoir engineer workflow more closely. For example: 

• File menu renamed Project menu to reflect content 
(Alt-F still opens the menu).

• Recent projects now appear in Project menu (up to 
ten projects).

• Macro operations moved to Macro menu.
• Extract Cell Data and Sim Input controls moved to 

the Data menu.
• The View menu now includes only the view 

choices useful for Tecplot RS users.
• You can now turn the toolbar and/or sidebar on 

and off in the View menu.
• We removed the 3D menu and moved the View 

Presets options to the View menu.
• The Write Data as Formatted Text add-on is now an 

integrated part of Tecplot RS and is included in the 
Data menu.
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• Some features with marginal use have been 
removed, including the Quick Edit dialog, the Iso-
Surface Details dialog, the ability to create zones 
from the Data menu, and the Advanced Quick 
Edit dialog.

Faster Data Loading: More capabilities with fewer clicks

• Large grid files load up to 40% faster.
• New toolbar icons open XY and grid loading dialogs 

directly. Click the Load XY Data button to load XY data, 
and the Load Grid Data button to load grid data.

• More file associations enable loading of multiple data 
files with fewer clicks.

• Load by dragging and dropping project files onto the 
Tecplot RS icon or onto the workspace to load all 
project content simply.

• Load XY data files by dragging and dropping a folder 
onto the Tecplot RS icon or onto the workspace; Tecplot 
RS loads all XY data files that it recognizes in the folder.

• New toolbar button launches the Manage Data dialog 
for quick access to manage loaded data sets.

Enhanced Comparison Capabilities: Comparison of data from 
multiple sources

• Comparison data sets included in Quick XY plots 
enable interaction with well production data while 
viewing grid solution plots.

• You can now extract and create an internal history 
data set from Eclipse history match runs so that you 
can compare simulation and history data for multiple 
runs without having to select unique variable names 
for history data. Sidebar option provides quick access 
to calculate the difference between simulation and 
history data.
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• Sum and Average controls in XY Entities plot type now 
apply to all comparison data sets, so that you can 
select a particular set of wells to compare across 
multiple data sets, then compare the properties as an 
instantaneous “group” by choosing to sum or average 
the data.

• You can now create user groups for all data sets rather 
than just one. Tecplot RS stores the new groups in the 
project and recreates them when you reload the project.

• Spreadsheet tool in Data menu lets you highlight and 
copy plot data to the clipboard so that you can paste it 
directly into a spreadsheet program (such as Microsoft 
Excel) for additional post-processing.

Data Interrogation: Improved tools for grid solutions

• Updated Probe dialog provides faster display of 
solution data.

• Addition of light source and translucency controls for 
iso-surfaces and slices enhances visualization of 3D 
objects.

• New streamtrace tool lets you interactively seed 
streamtraces in the reservoir flow. Inserting multiple 
streamtraces helps reveal the sweep area of an injector 
or determine the source of fluids moving toward a 
producer.

• New interactive 3D light source tool enhances visual 
perspective of reservoir. You can turn the light effect on 
and off in the Plot Controls sidebar.

• One-button sidebar control enables synchronization of 
Local Grid Refinements (LGRs) with their parent 
grids, so you can step through both grids concurrently 
while using step controls for just the LGRs.

• New bubble plot control provides the choice to scale 
grid plot bubbles by diameter or area proportional to 
the assigned variable values.



W
e l

co
m

e 
to

 T
ec

p
lo

t 
R

S
 2

0
1

0
 R

2
!

10

• Grid orientation, translation, rotation, and z-axis 
inflation now reside in the Grid Options dialog instead 
of in the grid loading process, enabling quick access to 
these features without reloading data.

Well Pattern Analysis: Strategic new tools

• You can now load well allocation factors generated by 
several streamline simulators.

• You can also load both constant and time-dependent 
well allocation factors from a user-created file.

• You can now define well patterns by interactively 
selecting the wells that participate in the pattern.

• With Tecplot RS 2010, you can calculate production 
data for well patterns and create a plot of the results to 
help determine effectiveness of particular injectors.

Supported Platforms
Tecplot, Inc. supports Tecplot RS on the following operating 
systems. The software may also run on operating system 
distributions similar to the ones listed here, but we cannot 
provide support for users running Tecplot RS on other 
systems.

Microsoft Windows Platforms

32-bit 64-bit

    XP (Service Pack 3)     XP (Service Pack 2)

    Vista (Service Pack 2)*

*. Vista and Windows 7 require that the installation 
be run as an administrator.

    Vista (Service Pack 2)*

    Windows 7*     Windows 7*
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Windows Configuration
Tecplot RS uses OpenGL 3D graphics, and will utilize high-
end 3D graphics cards. For best results, use a graphics card 
and operating system that supports OpenGL (almost all 
newer graphics cards do).

With certain system configurations, it is not uncommon to 
experience problems due to insufficient memory or poorly-
programmed graphics drivers. If problems arise on your 
system, please attempt the following:

1. Temporarily set the Hardware Acceleration option to 
None. To do this, add the following line to your 
tecplot.cfg file:

$!Interface OpenGLConfig{AllowHWAcceleration= No}                                       
If this fixes the problem, it is very likely your OpenGL 
driver was causing it. We recommend you install the 
latest driver for your graphics card from the 
manufacturer’s Web site. Setting Hardware 
Acceleration to None may substantially reduce 
drawing speed, so use this as the final solution only if 
nothing else works.

2. Try changing the Color Palette to 16-, 24-, or 32-bit 
color.

3. If operating on large data sets, you still may run into 
memory issues. If this is the case, try one of the 

Linux Platforms

32-bit 64-bit

    Red Hat Enterprise Linux 
(RHEL) 4, 5

    Red Hat Enterprise Linux 
(RHEL) 4, 5

    SUSE 10, 11     SUSE 9 (SP 4), 10, 11

    Ubuntu 6.06 LTS, 8.04 LTS*     Ubuntu 6.06 LTS, 8.04 LTS*

*. Ubuntu must be a Long Term Support (LTS) 
release.
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alternative Graphics Cache settings: Cache Only 
Lightweight Graphics Objects, or Do Not Cache 
Graphics. Choose “Performance Options” from the 
Options menu. On the Rendering page of the 
Performance dialog, choose the desired Graphics 
Cache setting and click OK. You can also make these 
your default settings by editing your tecplot.cfg file with 
a combination of commands. For Cache Only 
Lightweight Graphics, use:

$!Interface                                                                                    
UseDisplayLists = Yes                                           
CacheLightWeightDisplayListOnly = Yes

For Do Not Cache Graphics, use:
$!Interface UseDisplayLists = No

Linux Configuration
• Qt Display Customization

The default display settings for Qt software on Linux 
platforms may cause Tecplot RS to display graphics at 
less than optimal speeds. You can customize your Qt 
display settings by using the qtconfig utility included in 
the standard Tecplot RS installation (in the bin folder). 
To learn more, see the Installation Guide.

• Remote Display Issues
If you have a Network or Site license, you can run 
Tecplot RS on one computer and display it on a second 
computer (via an X server). However, if you are 
running the OpenGL version of Tecplot RS, the X server 
must have the GLX extensions. If you are working with 
a large grid file remotely, try using the -mesa option to 
minimize the number of OpenGL commands sent 
across the network.
When displayed remotely, Tecplot RS may exhibit 
substantially lower drawing speeds than when it is 
displayed locally, especially for text and geometries.
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Platform
-Indepen dent Issues

• Mesa Versions
Mesa, an OpenGL-equivalent graphics library, 
performs 3D rendering in software. It is typically used 
when hardware acceleration is unavailable or when 
working with remote display of large data.
The Mesa version of Tecplot RS functions more slowly, 
especially for 3D plotting. If you must run the Mesa 
version and display remotely, you can speed up the 
rendering for XY Line and 2D plots by setting the 
environment variable below. (On some machines, this 
may improve the speed of 3D plotting.)

export MESA_BACK_BUFFER=Pixmap

Platform-Independent Issues
• Graphics drivers

For best results, please make sure you are using the 
latest graphics drivers compatible with your 
hardware and operating system. You can obtain these 
from your graphics adapter vendor’s Web site. Old 
versions may have issues with Tecplot products 
(especially with larger data sets).
NVIDIA: http://www.nvidia.com/Download/
index.aspx
ATI: http://support.amd.com/us/gpudownload/Pages/
index.aspx
Intel: http://downloadcenter.intel.com/Default.aspx
Download the latest available driver for your system 
and adapter.

• Toolbar and sidebar docking
If you have trouble re-docking the new toolbar or 
dockable sidebar, you can run the RSReset utility (in the 
bin folder of your Tecplot RS installation). This will 
reset the window configuration(s) back to the default 
settings.
Or you can follow these steps:

http://www.nvidia.com/Download/index.aspx
http://www.nvidia.com/Download/index.aspx
http://support.amd.com/us/gpudownload/Pages/index.aspx
http://support.amd.com/us/gpudownload/Pages/index.aspx
http://downloadcenter.intel.com/Default.aspx
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1. Exit Tecplot RS.
2. Open regedit.exe (on Windows platforms, you can 

usually find this in C:\Windows).
3. Navigate to HKEY_CURRENT_USER/Software/

Tecplot/TecplotRS and expand the entry.
4. Delete the entry “mainwindow”.
5. Restart Tecplot RS.

Bug Updates
For a list of bugs fixed in Tecplot RS 2010 R2, visit:

http://download.tecplot.com/RS/bugs_fixed.html

For a list of known bugs in Tecplot RS 2010 R2, visit:

http://download.tecplot.com/RS/bugs.html

http://download.tecplot.com/RS/bugs.html
http://download.tecplot.com/RS/bugs_fixed.html
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